Login button not working

Need help with SmartFoxServer? You didn't find an answer in our documentation? Please, post your questions here!

Moderators: Lapo, Bax

Posts: 48
Joined: 18 Sep 2011, 17:45
Location: Wisconsin

Login button not working

Postby Buffy1011 » 19 Sep 2011, 22:06

So on my virtual world, I was going to login but the button wasn't working. Some of my staff members tried it, but it didn't work for them either.
I have the it and lib files on my host, and it has worked before, but it doesn't work now.
I also didn't update the file at any moment in the past day or so, just played with the config file a bit, but that shouldn't have hurt it I don't think.
Can somebody help me?
User avatar
Posts: 1698
Joined: 25 Feb 2008, 19:26
Location: New Zealand

Postby BigFIsh » 19 Sep 2011, 23:42

The problem could be anything, really. You and your staff need to figure out what the problem is.

I would suggest creating a very basic connection/login application. Once you get that working, then you probably would get your main application working.

There are a number of things that could be the cause:
- Local firewall
- Network firewall
- Cross domain policy
- Flash security policy
- Incorrect port/ip adress
- Incorrect login details
- Login extension crashing
- Database issue
- Flash crashing
- Incorrect extension zone
- Server not running
- and so on

Here's some tips to help you to narrow down the problem:
- Turn on the .debug flag for your SmartFoxClient instance, so that you can see the incoming/outgoing messages.
- Also use telnet to check if your computer can communicate to the target computer
- Use an external website tool to check if the ports is blocked or not
- Enable on <DebugIncomingMessages> and <DebugOutGoingMessages> in your config file.
- Check the logs

Lastly, please also refer to this sticky: Behind-a-router help
Smartfox's forum is my daily newspaper.
Posts: 48
Joined: 18 Sep 2011, 17:45
Location: Wisconsin

Postby Buffy1011 » 20 Sep 2011, 23:42

Is there a way to reset the config.xml file? I think I know the problem now
Posts: 148
Joined: 03 Aug 2010, 16:08

Postby Guy71173cp » 27 Sep 2011, 21:19

There is no way to reset the config file. Try keeping your one SmartFoxServer file, and try installing another one in a different path. Next, open the new one and copy the default config text. Then, delete the text in the first config file and paste the new one there. Then delete the new folder.

If that is confusing, tell me.
Posts: 48
Joined: 18 Sep 2011, 17:45
Location: Wisconsin

Postby Buffy1011 » 27 Sep 2011, 21:21

Kinda late reply there. xD I already solved this, but thanks for the tip!

Return to “SmartFoxServer 1.x Discussions and Help”

Who is online

Users browsing this forum: No registered users and 21 guests