AS3 API updated (v0.9.17)

Post here your questions about the Flash / Flex / Air API for SFS2X

Moderators: Lapo, Bax

User avatar
Bax
Site Admin
Posts: 4522
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

AS3 API updated (v0.9.17)

Postby Bax » 18 Jul 2011, 07:53

We just released an updated version of the AS3 API which fixes a bug caused by a library used internally (see this post).
We also updated the RC3 patch, so all users who downloaded it after Monday 18th, 2011 at 11:00 (GMT+2) already have the latest version.
For all the others, to avoid downloading the whole RC3 agains, you can use the following link to get the AS3 API only: http://www.smartfoxserver.com/2X/quickUpdates/SFS2X_API_AS3__0.9.17.zip
Paolo Bax
The SmartFoxServer Team
jamesr
Posts: 104
Joined: 14 Oct 2010, 14:56

Postby jamesr » 18 Jul 2011, 08:25

Hi Bax,

i've just downloaded the zip from the supplied link, but it doesn't contain a swc, only the files library.swf and catalog.xml.

Cheers,

James
User avatar
Bax
Site Admin
Posts: 4522
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Postby Bax » 18 Jul 2011, 08:28

It seems the zip program made some confusion... please download the file again.
Paolo Bax
The SmartFoxServer Team
jamesr
Posts: 104
Joined: 14 Oct 2010, 14:56

Postby jamesr » 18 Jul 2011, 08:29

thanks
jamesr
Posts: 104
Joined: 14 Oct 2010, 14:56

Postby jamesr » 18 Jul 2011, 08:34

Hi, it's still the same file?
User avatar
Bax
Site Admin
Posts: 4522
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Postby Bax » 18 Jul 2011, 08:38

No, it isn't. Clear your browser's cache.
Paolo Bax
The SmartFoxServer Team
jamesr
Posts: 104
Joined: 14 Oct 2010, 14:56

Postby jamesr » 18 Jul 2011, 08:39

I have done, 4 times. I'm still getting the same zip file with the two files in.
User avatar
rjgtav
Posts: 2813
Joined: 19 Apr 2009, 11:31
Location: Lisbon, Portugal

Postby rjgtav » 18 Jul 2011, 08:40

Hi jamesr. I can confirm that it is already the correct file. Try using another browser
Skills: SFS Pro, SFS2X, AS2.0/AS3.0, Java, HTML5/CSS3/JS, C#
Portfolio: https://rjgtav.wordpress.com/
SFS Tutorials: http://sfs-tutor.blogspot.com/ - Discontinued. Some examples may be bugged.
jamesr
Posts: 104
Joined: 14 Oct 2010, 14:56

Postby jamesr » 18 Jul 2011, 08:44

Thanks.

I'm using firefox 5 and even though i've cleared the cache multiple times and quit the browser, it's still downloads the zip file containing 2 files.

This may be a firefox issue as i've managed to download the unzipped swc using safari.
ChrisP
Posts: 7
Joined: 13 Jul 2011, 22:37

Postby ChrisP » 18 Jul 2011, 14:40

Hmmm, I just downloaded it as well and received the archive containing the swf and xml file. I'll try from a different browser I guess. But I hadn't downloaded it before for it to be cached.
ChrisP
Posts: 7
Joined: 13 Jul 2011, 22:37

Postby ChrisP » 18 Jul 2011, 14:45

Heh, I know what's happening :) For some reason when I double-click to unzip it in Finder on the Mac it also decides to unzip the SWC file (SWC files are zip files? I didn't know that) as well, so I end up with a SWF and the catalog.xml file.

Thanks for the fix!
mihai2011
Posts: 11
Joined: 01 Jun 2011, 06:41

library fix

Postby mihai2011 » 19 Jul 2011, 09:21

Prior to this library release, it was impossible to access user variables from client side.
Now this also works!
Thanks!
Hope there won't be any other bugs.We all invest a great deal of time and money in developing with your platform, and we expect it to be the best.
User avatar
Bax
Site Admin
Posts: 4522
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Postby Bax » 19 Jul 2011, 10:26

@mihai2011, we always do our best to deliver the best product, but you know that preventing any bug to appear in software is almost impossible, no matter how many tests you do.
Paolo Bax
The SmartFoxServer Team
User avatar
copet80
Posts: 42
Joined: 27 Apr 2010, 22:23
Location: Australia
Contact:

Postby copet80 » 02 Aug 2011, 04:26

For some reason after I updated the SWC, the problem still doesn't go away for me. Has anyone else experienced this?
User avatar
Lokos
Posts: 4
Joined: 10 Feb 2012, 03:34
Contact:

Postby Lokos » 10 Feb 2012, 17:08

I also experienced it copet80. At this moment, the ObjectMessageRequest class still isn't "fixed" after going all the possible available updates.

Return to “SFS2X ActionScript 3 API”

Who is online

Users browsing this forum: No registered users and 5 guests