[[NEW]] July 8th, 2014: SmartFoxServer 2X 2.9 Available!

Post here your questions about SFS2X. Here we discuss all server-side matters. For client API questions see the dedicated forums.

Moderators: Lapo, Bax

User avatar
Lapo
Site Admin
Posts: 20950
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: [[NEW]] July 8th, 2014: SmartFoxServer 2X 2.9 Available!

Postby Lapo » 22 Jul 2014, 10:38

Problem accessing /admin/AdminTool.html

I think your browser is pointing to an old location in cache, or something like that.

The url to the AdminTool is simply http://<your-ip-address>:8080/admin
Lapo
--
gotoAndPlay()
...addicted to flash games
User avatar
hoangdoanh
Posts: 253
Joined: 21 Jun 2013, 04:54
Location: Vietnam

Re: [[NEW]] July 8th, 2014: SmartFoxServer 2X 2.9 Available!

Postby hoangdoanh » 23 Jul 2014, 05:15

Hi Lapo

Sorry I still haven't got it.

By exception
java.io.IOException: Cannot read file: modules/npn/npn-1.7.0_51.mod
at org.eclipse.jetty.start.Modules.registerModule(Modules.java:405)
at org.eclipse.jetty.start.Modules.registerAll(Modules.java:395)
at org.eclipse.jetty.start.Main.processCommandLine(Main.java:561)
at org.eclipse.jetty.start.Main.main(Main.java:102)
at com.smartfoxserver.v2.http.JettyServer.start(JettyServer.java:35)
at com.smartfoxserver.v2.SmartFoxServer.start(SmartFoxServer.java:295)
at com.smartfoxserver.v2.Main.main(Main.java:27)


I understand that jetty server can not start, and jetty server is responsible for admin panel, so admin panel should not work with cache or no cache .

Am I right ?

Kind regards,
Doanh
User avatar
hoangdoanh
Posts: 253
Joined: 21 Jun 2013, 04:54
Location: Vietnam

Re: [[NEW]] July 8th, 2014: SmartFoxServer 2X 2.9 Available!

Postby hoangdoanh » 23 Jul 2014, 05:37

Hi Lapo

I already resolved that issue.

The reason is jetty require *.mod depend on version of JRE. In jetty npn folder there are only the files from npn-1.7.0_4.mod to npn-1.7.0_45.mod

But my JRE is npn-1.7.0_51, and it causes error.

By check some 4 latests npn files I found that they are the same, so I decided to create copy of npn-1.7.0_45.mod and rename to npn-1.7.0_51.mod.

And it works. This solution is not perfect, but currently I see it is accepted !

I found this issue only in macos installer ( my development environment ), it is not big issue now.

Cheers,
Doanh
User avatar
Lapo
Site Admin
Posts: 20950
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: [[NEW]] July 8th, 2014: SmartFoxServer 2X 2.9 Available!

Postby Lapo » 23 Jul 2014, 08:08

It would be best to use ./sfs2x-service start
This way SFS runs with its own runtime.
Lapo

--

gotoAndPlay()

...addicted to flash games
hhd90
Posts: 67
Joined: 21 Dec 2012, 05:17

Re: [[NEW]] July 8th, 2014: SmartFoxServer 2X 2.9 Available!

Postby hhd90 » 28 Jul 2014, 08:22

Today July 28th, 2014, I have just downloaded a new version SmartFoxServer but I can not install it on my server. Here is the error

Code: Select all

[root@B-GATE001 smartfox9]# ls
SFS2X_unix_2_9_0_64.tar.gz
[root@B-GATE001 smartfox9]# tar -xvzf SFS2X_unix_2_9_0_64.tar.gz
SmartFoxServer_2X/
SmartFoxServer_2X/.install4j/
SmartFoxServer_2X/.install4j/MessagesDefault
SmartFoxServer_2X/.install4j/firstrun
SmartFoxServer_2X/.install4j/i4j_extf_0_1uvewu1.utf8
SmartFoxServer_2X/.install4j/i4j_extf_1_1uvewu1_1nt6pqe.png
SmartFoxServer_2X/.install4j/i4j_extf_2_1uvewu1_x0i1l5.png
SmartFoxServer_2X/.install4j/i4j_extf_3_1uvewu1_8we6jo.png
SmartFoxServer_2X/.install4j/i4j_extf_4_1uvewu1_qdbe64.png
SmartFoxServer_2X/.install4j/i4j_extf_5_1uvewu1_66rivk.png
SmartFoxServer_2X/.install4j/i4j_extf_6_1uvewu1.txt
SmartFoxServer_2X/.install4j/i4jparams.conf
SmartFoxServer_2X/.install4j/i4jruntime.jar

gzip: stdin: invalid compressed data--format violated
tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now

My OS is

Code: Select all

CentOS release 6.4 (Final)
User avatar
Lapo
Site Admin
Posts: 20950
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: [[NEW]] July 8th, 2014: SmartFoxServer 2X 2.9 Available!

Postby Lapo » 28 Jul 2014, 09:27

It looks like your download failed, please download it again and retry.
Thanks
Lapo

--

gotoAndPlay()

...addicted to flash games
jeff
Posts: 14
Joined: 18 Jan 2013, 06:42
Contact:

Re: [[NEW]] July 8th, 2014: SmartFoxServer 2X 2.9 Available!

Postby jeff » 08 Aug 2014, 09:08

I got this log on my Log View when I try to restart smartfox, what issue is it?

java.lang.NullPointerException:
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
Exception: java.lang.NullPointerException
Message: *** Null ***
Description: Error while handling client request in extension: { Ext: Admin, Type: JAVA, Lev: ZONE, { Zone: --=={{{ AdminZone }}}==-- }, {} }
Extension Cmd: dashboard.getData
+--- --- ---+
Stack Trace:
+--- --- ---+
com.smartfoxserver.v2.admin.handlers.DashboardModuleReqHandler.handleAdminRequest(DashboardModuleReqHandler.java:108)
com.smartfoxserver.v2.admin.handlers.BaseAdminModuleReqHandler.handleClientRequest(BaseAdminModuleReqHandler.java:58)
com.smartfoxserver.v2.extensions.SFSExtension.handleClientRequest(SFSExtension.java:208)
com.smartfoxserver.v2.controllers.v290.ExtensionReqController.processRequest(ExtensionReqController.java:174)
com.smartfoxserver.v2.controllers.v290.ExtensionReqController$1.run(ExtensionReqController.java:68)
java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
java.lang.Thread.run(Unknown Source)
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
User avatar
Lapo
Site Admin
Posts: 20950
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: [[NEW]] July 8th, 2014: SmartFoxServer 2X 2.9 Available!

Postby Lapo » 08 Aug 2014, 09:36

Make sure you clear your browser's cache and try again.
This is usually caused by the browser using the cached old version of the AdminTool.

Thanks
Lapo

--

gotoAndPlay()

...addicted to flash games
jeff
Posts: 14
Joined: 18 Jan 2013, 06:42
Contact:

Re: [[NEW]] July 8th, 2014: SmartFoxServer 2X 2.9 Available!

Postby jeff » 12 Aug 2014, 02:34

Lapo wrote:Make sure you clear your browser's cache and try again.
This is usually caused by the browser using the cached old version of the AdminTool.

Thanks


I have clear browser's cache but the exception are still showing on the log view, everytime I restart or login to the AdminTool

java.lang.NullPointerException:
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
Exception: java.lang.NullPointerException
Message: *** Null ***
Description: Error while handling client request in extension: { Ext: Admin, Type: JAVA, Lev: ZONE, { Zone: --=={{{ AdminZone }}}==-- }, {} }
Extension Cmd: dashboard.getData
+--- --- ---+
Stack Trace:
+--- --- ---+
com.smartfoxserver.v2.entities.managers.SFSStatsManager.getTotalOutBytes(SFSStatsManager.java:114)
com.smartfoxserver.v2.admin.handlers.DashboardModuleReqHandler.handleAdminRequest(DashboardModuleReqHandler.java:114)
com.smartfoxserver.v2.admin.handlers.BaseAdminModuleReqHandler.handleClientRequest(BaseAdminModuleReqHandler.java:58)
com.smartfoxserver.v2.extensions.SFSExtension.handleClientRequest(SFSExtension.java:208)
com.smartfoxserver.v2.controllers.v290.ExtensionReqController.processRequest(ExtensionReqController.java:174)
com.smartfoxserver.v2.controllers.v290.ExtensionReqController$1.run(ExtensionReqController.java:68)
java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
java.lang.Thread.run(Unknown Source)
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
User avatar
Lapo
Site Admin
Posts: 20950
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: [[NEW]] July 8th, 2014: SmartFoxServer 2X 2.9 Available!

Postby Lapo » 12 Aug 2014, 08:28

What browser and OS is this?
Can you try with an other browser, or maybe from another computer to see if you get the same effect.

We have installed at least 15 copies of SFS2X 2.9 and never had this error, which is client generated. So I highly suspect that it's a client-related problem.

Thanks
Lapo

--

gotoAndPlay()

...addicted to flash games
jeff
Posts: 14
Joined: 18 Jan 2013, 06:42
Contact:

Re: [[NEW]] July 8th, 2014: SmartFoxServer 2X 2.9 Available!

Postby jeff » 12 Aug 2014, 09:00

Lapo wrote:What browser and OS is this?
Can you try with an other browser, or maybe from another computer to see if you get the same effect.

We have installed at least 15 copies of SFS2X 2.9 and never had this error, which is client generated. So I highly suspect that it's a client-related problem.

Thanks


I am using imac and test on safari, chrome and firefox
User avatar
Lapo
Site Admin
Posts: 20950
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: [[NEW]] July 8th, 2014: SmartFoxServer 2X 2.9 Available!

Postby Lapo » 13 Aug 2014, 13:28

Which Mac OS X version?
We run M.Lion and Mavericks on most of our machines.

Thanks
Lapo

--

gotoAndPlay()

...addicted to flash games
jeff
Posts: 14
Joined: 18 Jan 2013, 06:42
Contact:

Re: [[NEW]] July 8th, 2014: SmartFoxServer 2X 2.9 Available!

Postby jeff » 02 Sep 2014, 03:52

I am using Mavericks, I have tried to access another machine which install as Windows still show same error every time I login to admin tool.
User avatar
Lapo
Site Admin
Posts: 20950
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: [[NEW]] July 8th, 2014: SmartFoxServer 2X 2.9 Available!

Postby Lapo » 02 Sep 2014, 09:49

Unfortunately we have no way to reproduce this problem. It sounds like your installation might be corrupted.

I would suggest to download the installer again and start from a fresh new installation. The new one is expected to work without problems.
Before testing the AdminTool make sure to clean the cache once again, and make sure that when it loads the version number is 1.5.0. You can see the version number if you click on the small icon in the lower right hand corner.

Thanks
Lapo

--

gotoAndPlay()

...addicted to flash games
jeff
Posts: 14
Joined: 18 Jan 2013, 06:42
Contact:

Re: [[NEW]] July 8th, 2014: SmartFoxServer 2X 2.9 Available!

Postby jeff » 24 Nov 2014, 12:30

I have clear my cache and the version is 1.5.0, and I have update to patch 2.9.2, but the error still exist, any idea?

Return to “SFS2X Questions”

Who is online

Users browsing this forum: No registered users and 18 guests