How do I allow admins into the admin panel....

Post here your questions about SFS2X. Here we discuss all server-side matters. For client API questions see the dedicated forums.

Moderators: Lapo, Bax

Ninjaoninja2
Posts: 194
Joined: 22 Sep 2013, 23:33

How do I allow admins into the admin panel....

Postby Ninjaoninja2 » 16 Nov 2013, 01:41

Hello Again Friendly Support,
I need help with adding people to my admin panel that are not on my local network the guide confuses me can you try to walk me through it?
User avatar
rjgtav
Posts: 2813
Joined: 19 Apr 2009, 11:31
Location: Lisbon, Portugal

Re: How do I allow admins into the admin panel....

Postby rjgtav » 16 Nov 2013, 02:56

Good evening,

In order to configure multiple administrator accounts you'll have to configure the Remote Administrators setting on the Server Configurator module of the AdminTool.
You can find a more detailed explanation of all the options at the documentation, on the "Remote Admin tab" section:
http://docs2x.smartfoxserver.com/Gettin ... nfigurator

Basically, you'll have to either create an Administrator account for each person or use the same one for all of you.
Then, if you want to increase the security, you can restrict who can enter the AdminTool by their IP.
You can also configure the Administrator TCP port, to increase the security even further, as connections on the wrong port will be refused (Note: If the user can't connect via Socket, the AdminTool will try connecting via BlueBox, which will use a different port and therefore be prevented by the server if this setting is enabled).

Hope this helps
Skills: SFS Pro, SFS2X, AS2.0/AS3.0, Java, HTML5/CSS3/JS, C#
Portfolio: https://rjgtav.wordpress.com/
SFS Tutorials: http://sfs-tutor.blogspot.com/ - Discontinued. Some examples may be bugged.
Ninjaoninja2
Posts: 194
Joined: 22 Sep 2013, 23:33

Re: How do I allow admins into the admin panel....

Postby Ninjaoninja2 » 17 Nov 2013, 00:19

rjgtav wrote:Good evening,

In order to configure multiple administrator accounts you'll have to configure the Remote Administrators setting on the Server Configurator module of the AdminTool.
You can find a more detailed explanation of all the options at the documentation, on the "Remote Admin tab" section:
http://docs2x.smartfoxserver.com/Gettin ... nfigurator

Basically, you'll have to either create an Administrator account for each person or use the same one for all of you.
Then, if you want to increase the security, you can restrict who can enter the AdminTool by their IP.
You can also configure the Administrator TCP port, to increase the security even further, as connections on the wrong port will be refused (Note: If the user can't connect via Socket, the AdminTool will try connecting via BlueBox, which will use a different port and therefore be prevented by the server if this setting is enabled).

Hope this helps

It still didn't work none of my staff members still cannot connect (they are not on the same network)
User avatar
Bax
Site Admin
Posts: 4522
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Re: How do I allow admins into the admin panel....

Postby Bax » 18 Nov 2013, 09:44

Make sure your server is binding the right IP address (General tab of the AdminTool's Server Configurator module).
By default the server is bound to 127.0.0.1, making it unreachable other than from the same computer.
Paolo Bax
The SmartFoxServer Team
Ninjaoninja2
Posts: 194
Joined: 22 Sep 2013, 23:33

Re: How do I allow admins into the admin panel....

Postby Ninjaoninja2 » 18 Nov 2013, 19:00

So would to do that I would go into the server configurator and go under the general tab and change the two localhost ips to the ip i opened the tcp and udp ports 9933
User avatar
Bax
Site Admin
Posts: 4522
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Re: How do I allow admins into the admin panel....

Postby Bax » 19 Nov 2013, 09:14

Yes. That's the fundamental step to make the server "visible" on the network.
Paolo Bax
The SmartFoxServer Team
Ninjaoninja2
Posts: 194
Joined: 22 Sep 2013, 23:33

Re: How do I allow admins into the admin panel....

Postby Ninjaoninja2 » 20 Nov 2013, 03:34

Bax wrote:Yes. That's the fundamental step to make the server "visible" on the network.

It still didn't work when my buddy goes to the page it says Sorry But Google Chrome could not find this webpage or something like that
User avatar
Bax
Site Admin
Posts: 4522
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Re: How do I allow admins into the admin panel....

Postby Bax » 20 Nov 2013, 08:43

What web page sorry? The AdminTool page? Or your game?
Paolo Bax
The SmartFoxServer Team
Ninjaoninja2
Posts: 194
Joined: 22 Sep 2013, 23:33

Re: How do I allow admins into the admin panel....

Postby Ninjaoninja2 » 20 Nov 2013, 19:11

The admin tool
User avatar
Bax
Site Admin
Posts: 4522
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Re: How do I allow admins into the admin panel....

Postby Bax » 21 Nov 2013, 09:23

If they can't even reach the webpage, then the server is unreachable. Maybe you have a firewall preventing the connection. Also check the server logs, to make sure there are no startup errors.
Please follow the "post installation tasks" described on this page: http://docs2x.smartfoxserver.com/Gettin ... stallation
Paolo Bax
The SmartFoxServer Team
Ninjaoninja2
Posts: 194
Joined: 22 Sep 2013, 23:33

Re: How do I allow admins into the admin panel....

Postby Ninjaoninja2 » 23 Nov 2013, 01:15

Hey Baxthanks so much my friend can now get to the Admin tool Page but for some unknown reason he cannot log in to the admin tool using the public IP address as the host
User avatar
Bax
Site Admin
Posts: 4522
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Re: How do I allow admins into the admin panel....

Postby Bax » 23 Nov 2013, 12:24

I think it's a configuration issue. Please post a screenshot of the Remote Admin tab of the Server Configurator module.
Paolo Bax
The SmartFoxServer Team
Ninjaoninja2
Posts: 194
Joined: 22 Sep 2013, 23:33

Re: How do I allow admins into the admin panel....

Postby Ninjaoninja2 » 23 Nov 2013, 18:15

Bax wrote:I think it's a configuration issue. Please post a screenshot of the Remote Admin tab of the Server Configurator module.

All right, Here you go: Image
User avatar
rjgtav
Posts: 2813
Joined: 19 Apr 2009, 11:31
Location: Lisbon, Portugal

Re: How do I allow admins into the admin panel....

Postby rjgtav » 25 Nov 2013, 01:07

Hi,

For testing purposes, try setting the Administration TCP Port setting to -1 and then restart the server.
If your buddy is able to login after this, then he's either connecting to the wrong port (please double check) or his firewall is preventing him from establishing a direct connection.

Hope this helps
Skills: SFS Pro, SFS2X, AS2.0/AS3.0, Java, HTML5/CSS3/JS, C#
Portfolio: https://rjgtav.wordpress.com/
SFS Tutorials: http://sfs-tutor.blogspot.com/ - Discontinued. Some examples may be bugged.

Return to “SFS2X Questions”

Who is online

Users browsing this forum: Aldenea, DavinVicy, DerikFent, JerodSa, Kevengar and 30 guests