Smartfox is not responding after first fail connection

Post here your questions about the Flash / Flex / Air API for SFS2X

Moderators: Lapo, Bax

User avatar
levancho
Posts: 71
Joined: 27 Jun 2011, 16:03

Smartfox is not responding after first fail connection

Postby levancho » 11 Jul 2012, 13:31

hi,

I have an application where i can pick the servers where i want to connect my client, we have local servers and integration servers,
problem is that if I try to connect client to server that is down, I get following error in client :

Code: Select all

## SocketError: [IOErrorEvent type="ioError" bubbles=false cancelable=false eventPhase=2 text="Error #2031: Socket Error. URL: 127.0.0.1" errorID=2031]
## BlueBox Error: Error #2032: Stream Error. URL: http://127.0.0.1:8181/BlueBox/BlueBox.do


this is normal ,but,

all further attempts to connect same smart fox instance to other servers that are, for sure running, fails, and mysterious thing is that
I do not get feedback form smart fox client anymore, its just stays silent, no error messages or nothing,and if i keep clicking connect then I see in the console following info:
[SFS - WARN] A connection attempt is already in progress

this seems like a bug in smart fox client,

NOTE: if you need to reproduce the error I can send you my clinet air app (via email or PM).

Regards
Levan
User avatar
rjgtav
Posts: 2813
Joined: 19 Apr 2009, 11:31
Location: Lisbon, Portugal

Re: Smartfox is not responding after first fail connection

Postby rjgtav » 11 Jul 2012, 13:37

Hi.
I think this is the same issue as here.
Skills: SFS Pro, SFS2X, AS2.0/AS3.0, Java, HTML5/CSS3/JS, C#
Portfolio: https://rjgtav.wordpress.com/
SFS Tutorials: http://sfs-tutor.blogspot.com/ - Discontinued. Some examples may be bugged.
User avatar
levancho
Posts: 71
Joined: 27 Jun 2011, 16:03

Re: Smartfox is not responding after first fail connection

Postby levancho » 12 Jul 2012, 03:53

UPDATE:

killConnection does not work,

recreating smartfox object also is not good because then I have to reload config file, via service call
User avatar
Lapo
Site Admin
Posts: 21603
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: Smartfox is not responding after first fail connection

Postby Lapo » 12 Jul 2012, 07:42

1) The error should only appear in the console not on the client (of course if you test in FB debug mode or Flash you will see that)
2) You should get the CONNECTION event with success parameter set to false
3) It is necessary to recreate the SmartFox object to start a new connection.
Lapo
--
gotoAndPlay()
...addicted to flash games

Return to “SFS2X ActionScript 3 API”

Who is online

Users browsing this forum: No registered users and 0 guests