SmartFoxServer 2X Release Candidate 3

Post here your questions about SFS2X. Here we discuss all server-side matters. For client API questions see the dedicated forums.

Moderators: Lapo, Bax

User avatar
Bax
Site Admin
Posts: 4515
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

SmartFoxServer 2X Release Candidate 3

Postby Bax » 27 Jun 2011, 19:44

We just published the Release Candidate 3 version of SmartFoxServer 2X!

This version brings new features and improvements mainly from the discussions and bug reports since RC2 was released. Thanks for your feedback and keep it coming. :)

The RC3 is available on the download page and is provided as a patch that requires a quick manual installation as described in the contained README.html file. Read the release notes in the next post.

During the next weeks we will concentrate our efforts on the last improvements to finally get to the official release of SmartFoxServer 2X!
Last edited by Bax on 20 Jul 2011, 07:22, edited 2 times in total.
Paolo Bax
The SmartFoxServer Team
User avatar
Bax
Site Admin
Posts: 4515
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Release notes

Postby Bax » 27 Jun 2011, 19:47

Release notes

Server
[NEW] Final licensing system based on a centralized License Server, allowing SFS2X instances to be moved without any intervention from the SmartFoxServer Team (namely IP change procedure) — More informations will be provided to existing customers in a dedicated email.
[NEW] Server-side "force login" system implemented: it allows a user to login from another client while a previous session is already active, closing the latter.
[NEW] Support for client-server lag measurement added.
[NEW] Server halt and soft restart functionalities added to Admin Tool.
[NEW] License Manager module added to Admin Tool.
[NEW] Dropdown selectors added to AdminTool's Zone Configurator module to simplify Extension assignement to Zones/Rooms.
[NEW] JVM settings tab added to AdminTool's Server Configurator module.
[NEW] Flag to activate/deactivate the "force login" system added to AdminTool's Zone Configurator module.
[NEW] Flag to activate/deactivate the mailer added to AdminTool's Server Configurator module.
[NEW] Zone filtering added to AdminTool's BlueBox Monitor module.
[NEW] Sessions counter added to AdminTool's BlueBox Monitor module.
---
[FIXED] Room identity issue: Rooms are replaced in the Room List with a new version upon Join. This can lead to possible subtle equality problems.
[FIXED] Issue in UDP initialization, not released when a logout is performed.
[FIXED] DBManager.executeQuery(String sql, Object[] params) method doesn't process the parameters.
[FIXED] Room.isFull property doesn't report true even if all player slots are taken.
[FIXED] Packets compression using BEST_SPEED setting is not 100% compatible with ActionScript3.
[FIXED] Wrong time format in AdminTool's Ban Manager module.
[FIXED] Incorrect ban message (reason of banning) sent to client.
[FIXED] Minor bugs and glitches.

ActionScript 3 API
[NEW] Client-server lag measurement functionality added.
[NEW] Error codes added to params object of all error events.
---
[FIXED] A memory leak is caused by the Data Structures library; update to latest version.
[FIXED] Bug in SFSRoomManager and SFSUserManager: incorrect removal of Room and User objects from hashmaps.
[FIXED] Bug with unsigned word in header.
[FIXED] Error in binary math for Long conversion including negative Longs.
[FIXED] ASDoc errors.

C# / Unity API
[NEW] Client-server lag measurement functionality added.
[NEW] Hostnames now can be used for UDP connection.
[NEW] Configuration loader now checks for required nodes in config file.
[NEW] Error codes added to params object of all error events (see this document).
[NEW] BlueBox and UDP improvements.
---
[FIXED] CONNECTION_LOST event not triggered by bans and other disconnection reasons.
[FIXED] API doc errors.
[FIXED] Minor bugs and glitches.

Java client API
[NEW] JavaDoc added.
[NEW] Client-server lag measurement functionality added.
[NEW] Configuration loader now checks for required nodes in config file.
[NEW] Error codes added to params object of all error events (see this document).
[NEW] BlueBox support.
[NEW] UDP support.
---
[FIXED] String.isEmpty does not support earlier Android versions.
[FIXED] CONNECTION_LOST event not triggered by bans and other disconnection reasons.
[FIXED] Minor bugs and glitches
Paolo Bax
The SmartFoxServer Team
ifernandez
Posts: 21
Joined: 16 Jul 2010, 17:02

Postby ifernandez » 27 Jun 2011, 21:25

Hi,

After installing the RC3 path i'm having some strange output in the server log:

Code: Select all

17:17:23,022 WARN  [main] mortbay.log     - Failed to read file: \SFS2X-RC1a\SFS2X\lib\._sfs2x.jar
java.util.zip.ZipException: error in opening zip file
        at java.util.zip.ZipFile.open(Native Method)
        at java.util.zip.ZipFile.<init>(Unknown Source)
        at java.util.jar.JarFile.<init>(Unknown Source)
        at java.util.jar.JarFile.<init>(Unknown Source)
        at org.mortbay.jetty.webapp.TagLibConfiguration.configureWebApp(TagLibConfiguration.java:174)
        at org.mortbay.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1279)
        at org.mortbay.jetty.handler.ContextHandler.doStart(ContextHandler.java:518)
        at org.mortbay.jetty.webapp.WebAppContext.doStart(WebAppContext.java:499)
        at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
        at org.mortbay.jetty.handler.HandlerCollection.doStart(HandlerCollection.java:152)
        at org.mortbay.jetty.handler.ContextHandlerCollection.doStart(ContextHandlerCollection.java:156)
        at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
        at org.mortbay.jetty.handler.HandlerCollection.doStart(HandlerCollection.java:152)
        at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
        at org.mortbay.jetty.handler.HandlerWrapper.doStart(HandlerWrapper.java:130)
        at org.mortbay.jetty.Server.doStart(Server.java:224)
        at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
        at com.smartfoxserver.v2.http.SFSHttpServer.start(SFSHttpServer.java:110)
        at com.smartfoxserver.v2.SmartFoxServer.start(SmartFoxServer.java:231)
        at com.smartfoxserver.v2.Main.main(Main.java:31)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)
        at com.exe4j.runtime.WinLauncher.main(Unknown Source)
        at com.install4j.runtime.launcher.WinLauncher.main(Unknown Source)


And also this lines

Code: Select all

17:17:21,027 DEBUG [main] impl.StandardFileSystemManager     - Skipping provider "org.apache.commons.vfs.provider.ftp.FtpFileProvider" because required class "org.apache.commons.net.ftp.FTPFile" is no
t available.
17:17:21,028 DEBUG [main] impl.StandardFileSystemManager     - Skipping provider "org.apache.commons.vfs.provider.http.HttpFileProvider" because required class "org.apache.commons.httpclient.HttpClien
t" is not available.
17:17:21,029 DEBUG [main] impl.StandardFileSystemManager     - Skipping provider "org.apache.commons.vfs.provider.https.HttpsFileProvider" because required class "org.apache.commons.httpclient.HttpCli
ent" is not available.
17:17:21,031 DEBUG [main] impl.StandardFileSystemManager     - Skipping provider "org.apache.commons.vfs.provider.sftp.SftpFileProvider" because required class "com.jcraft.jsch.JSch" is not available.




I don't remember the those lines in the previous patch (RC2a). Even with those lines in the log the server says that is ready like always. And works, i was wondering if that lines mean something is wrong with my installation.

Thanks

Ivan[/code]
User avatar
rjgtav
Posts: 2813
Joined: 19 Apr 2009, 11:31
Location: Lisbon, Portugal

Postby rjgtav » 27 Jun 2011, 22:11

hi. Great update you have there, keep it going :-)

Just a question, were the changes to the privilege system lapo said applied in this release?
Skills: SFS Pro, SFS2X, AS2.0/AS3.0, Java, HTML5/CSS3/JS, C#
Portfolio: https://rjgtav.wordpress.com/
SFS Tutorials: http://sfs-tutor.blogspot.com/ - Discontinued. Some examples may be bugged.
User avatar
aaulia
Posts: 31
Joined: 28 May 2011, 18:50

Postby aaulia » 28 Jun 2011, 05:08

ifernandez wrote:Hi,

After installing the RC3 path i'm having some strange output in the server log:

[/code]


I don't remember the those lines in the previous patch (RC2a). Even with those lines in the log the server says that is ready like always. And works, i was wondering if that lines mean something is wrong with my installation.

Thanks

Ivan[/code]


While a bit different, I can also confirm there is problem reading SFS2X/lib/._sfs2x.jar when I start the server (from RC2a -> RC3)

EDIT:
Also so now it is not possible to login to AdminTool from any IP by emptying the allowedRemoteAddress ? Since I can login even though I emptied it.
User avatar
Bax
Site Admin
Posts: 4515
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Postby Bax » 28 Jun 2011, 06:25

Please delete the ._sfs2x.jar file, as it was left by the OSX system we use. Sorry.
Paolo Bax
The SmartFoxServer Team
User avatar
Bax
Site Admin
Posts: 4515
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Postby Bax » 28 Jun 2011, 07:30

We have uploaded a new compressed file that should fix the issue reported by ifernandez and aaulia.
Paolo Bax
The SmartFoxServer Team
User avatar
rjgtav
Posts: 2813
Joined: 19 Apr 2009, 11:31
Location: Lisbon, Portugal

Postby rjgtav » 28 Jun 2011, 08:10

Well, after applying this patch, i can no longer configure any Zone using the Zone configurator. I always get a NullPointerException... Here are the logs (only the important parts):

28 Jun 2011 10:01:50,485 INFO [main] entities.managers.SFSBannedUserStorage - BanUserStorage initialized
28 Jun 2011 10:01:50,503 INFO [main] entities.managers.SFSBannedUserManager - BanUser data loaded: 0 records.
28 Jun 2011 10:01:50,519 INFO [main] v2.config.SFSConfigurator - Loading: zones\AoD.zone.xml
28 Jun 2011 10:01:50,598 INFO [main] v2.config.SFSConfigurator - Loading: zones\FPS.zone.xml
28 Jun 2011 10:01:50,644 INFO [main] v2.config.SFSConfigurator - Loading: zones\GameLobby.zone.xml
28 Jun 2011 10:01:50,676 INFO [main] v2.config.SFSConfigurator - Loading: zones\GameManager.zone.xml
28 Jun 2011 10:01:50,722 INFO [main] v2.config.SFSConfigurator - Loading: zones\RFPS.zone.xml
28 Jun 2011 10:01:50,750 INFO [main] v2.config.SFSConfigurator - Loading: zones\SimpleChat.zone.xml
28 Jun 2011 10:01:50,793 INFO [main] entities.managers.SFSZoneManager -
.
.
.
28 Jun 2011 10:03:10,810 ERROR [com.smartfoxserver.v2.controllers.ExtensionController-1] v2.controllers.ExtensionController -
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
Exception: java.lang.NullPointerException
Message: *** Null ***
Description: Error while handling client request in extension: { Ext: Admin, Type: JAVA, Lev: ZONE, { Zone: --=={{{ AdminZone }}}==-- }, {} }
Extension Cmd: zoneConfig.getZoneConfig
+--- --- ---+
Stack Trace:
+--- --- ---+
com.smartfoxserver.v2.admin.helper.ExtensionsHelper.loadExtensionsData(ExtensionsHelper.java:98)
com.smartfoxserver.v2.admin.handlers.ZoneConfigModuleReqHandler.handleClientRequest(ZoneConfigModuleReqHandler.java:147)
com.smartfoxserver.v2.extensions.SFSExtension.handleClientRequest(SFSExtension.java:192)
com.smartfoxserver.v2.controllers.ExtensionController.processRequest(ExtensionController.java:137)
com.smartfoxserver.bitswarm.controllers.AbstractController.run(AbstractController.java:96)
java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
java.lang.Thread.run(Unknown Source)
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::


As you can see, in the beginning it successfully loads the Zones configuration files and successfully starts them. Btw, in the Zone configurator it shows correctly the Zones names and their rooms, I can't edit neither of them.

Another question, can't you really edit the log files name generator? As currently it generates the name as smartfox.log.date. Can you change it to smartfox.date.log?

P.S. The server configurator module works fine.
Skills: SFS Pro, SFS2X, AS2.0/AS3.0, Java, HTML5/CSS3/JS, C#
Portfolio: https://rjgtav.wordpress.com/
SFS Tutorials: http://sfs-tutor.blogspot.com/ - Discontinued. Some examples may be bugged.
User avatar
Bax
Site Admin
Posts: 4515
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Postby Bax » 28 Jun 2011, 08:47

rjgtav, of course we are not able to reproduce the issue, sorry :(
Could you please verify if a specific zone is causing the problem?
You should remove all the zone configurations, and try running the AdminTool. Then add them one by one, always checking if the error is thrown (you will need to restart the server each time you add a zone, sorry).
Paolo Bax
The SmartFoxServer Team
User avatar
rjgtav
Posts: 2813
Joined: 19 Apr 2009, 11:31
Location: Lisbon, Portugal

Postby rjgtav » 28 Jun 2011, 09:36

Hi. Yes it is happening with all my zones... It gives that error in every zone... Do you want me to send you their configuration files to check if it is due to one of the new parameters be missing?

Will do now the tests, will then edit this post according to the results

1# Test: tried to edit all of them, one by one. Results:
- All zones give the nullPointerException, including their rooms

2#Test: tried to add a new zone. Result:
- It gives the same nullPointerException when trying to add a new one

3# Test: removed all of the zones. Tried to add a new one. Result:
- It still gives the same nullPointerException error...

Any ideas? If you need more information just ask :-)
Skills: SFS Pro, SFS2X, AS2.0/AS3.0, Java, HTML5/CSS3/JS, C#
Portfolio: https://rjgtav.wordpress.com/
SFS Tutorials: http://sfs-tutor.blogspot.com/ - Discontinued. Some examples may be bugged.
Sappho
Posts: 74
Joined: 29 Mar 2009, 19:23
Location: Slovakia

Postby Sappho » 28 Jun 2011, 10:08

After applying the patch we get an error straight away:

~/sfs/SFS2X$ ./sfs2x.sh
Error occurred during initialization of VM
java/lang/NoClassDefFoundError: java/lang/Object

Seems like a JVM problem but why when it worked before, and we just applied the patch which went ok with SUCCESS. Any idea?
User avatar
Bax
Site Admin
Posts: 4515
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Postby Bax » 28 Jun 2011, 11:00

Sappho wrote:After applying the patch we get an error straight away:

~/sfs/SFS2X$ ./sfs2x.sh
Error occurred during initialization of VM
java/lang/NoClassDefFoundError: java/lang/Object

Seems like a JVM problem but why when it worked before, and we just applied the patch which went ok with SUCCESS. Any idea?

Sappho, what operating system are you using?
Paolo Bax
The SmartFoxServer Team
User avatar
Bax
Site Admin
Posts: 4515
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Postby Bax » 28 Jun 2011, 11:08

rjgtav wrote:Hi. Yes it is happening with all my zones... It gives that error in every zone... Do you want me to send you their configuration files to check if it is due to one of the new parameters be missing?

Will do now the tests, will then edit this post according to the results

1# Test: tried to edit all of them, one by one. Results:
- All zones give the nullPointerException, including their rooms

2#Test: tried to add a new zone. Result:
- It gives the same nullPointerException when trying to add a new one

3# Test: removed all of the zones. Tried to add a new one. Result:
- It still gives the same nullPointerException error...

Any ideas? If you need more information just ask :-)


rjgtav, can you please send your zones and extensions folder?
Is the error happening when opening the a zone in the zone configurator?
Paolo Bax
The SmartFoxServer Team
Sappho
Posts: 74
Joined: 29 Mar 2009, 19:23
Location: Slovakia

Postby Sappho » 28 Jun 2011, 11:14

Here is the info for you bax and how we solved it:

OS: Solaris

due to a conflicts with existing installed JAVA following lines were removed from sfs2x.sh script:

if [ -d "$JRE_FOLDER" ]; then
JAVA_CMD="../jre/bin/java"
fi
User avatar
rjgtav
Posts: 2813
Joined: 19 Apr 2009, 11:31
Location: Lisbon, Portugal

Postby rjgtav » 28 Jun 2011, 11:21

bax wrote:
rjgtav wrote:Hi. Yes it is happening with all my zones... It gives that error in every zone... Do you want me to send you their configuration files to check if it is due to one of the new parameters be missing?

Will do now the tests, will then edit this post according to the results

1# Test: tried to edit all of them, one by one. Results:
- All zones give the nullPointerException, including their rooms

2#Test: tried to add a new zone. Result:
- It gives the same nullPointerException when trying to add a new one

3# Test: removed all of the zones. Tried to add a new one. Result:
- It still gives the same nullPointerException error...

Any ideas? If you need more information just ask :-)


rjgtav, can you please send your zones and extensions folder?
Is the error happening when opening the a zone in the zone configurator?


Just sent the files to support [at] smartfoxserver [dot] com. The error happens with every zone and, even after removing all of them, it happens when adding a new one.
Skills: SFS Pro, SFS2X, AS2.0/AS3.0, Java, HTML5/CSS3/JS, C#
Portfolio: https://rjgtav.wordpress.com/
SFS Tutorials: http://sfs-tutor.blogspot.com/ - Discontinued. Some examples may be bugged.

Return to “SFS2X Questions”

Who is online

Users browsing this forum: No registered users and 19 guests