Receiving 503

Submit all your BlueBox related questions or report a bug here!

Moderators: Lapo, Bax

Posts: 4
Joined: 02 Apr 2010, 16:38

Receiving 503

Postby jarruda » 02 Apr 2010, 16:44

When attempting to connect to BlueBox via the Java API, I am not receiving a reply at all from the server other than a 200.

When I access the debug URL (http://[my domain]:8080/BlueBox/, I receive the following information:

Code: Select all


Problem accessing /BlueBox/ Reason:

    java.lang.NumberFormatException: null

Caused by:

javax.servlet.UnavailableException: java.lang.NumberFormatException: null
   at org.mortbay.jetty.servlet.ServletHolder.makeUnavailable(
   at org.mortbay.jetty.servlet.ServletHolder.initServlet(
   at org.mortbay.jetty.servlet.ServletHolder.getServlet(
   at org.mortbay.jetty.servlet.ServletHolder.handle(
   at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(
   at it.gotoandplay.smartfoxserver.httpbox.filter.SessionIDFilter.doFilter(
   at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(
   at org.mortbay.jetty.servlet.ServletHandler.handle(
   at org.mortbay.jetty.servlet.SessionHandler.handle(
   at org.mortbay.jetty.handler.ContextHandler.handle(
   at org.mortbay.jetty.webapp.WebAppContext.handle(
   at org.mortbay.jetty.handler.ContextHandlerCollection.handle(
   at org.mortbay.jetty.handler.HandlerCollection.handle(
   at org.mortbay.jetty.handler.HandlerWrapper.handle(
   at org.mortbay.jetty.Server.handle(
   at org.mortbay.jetty.HttpConnection.handleRequest(
   at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(
   at org.mortbay.jetty.HttpParser.parseNext(
   at org.mortbay.jetty.HttpParser.parseAvailable(
   at org.mortbay.jetty.HttpConnection.handle(
   at org.mortbay.thread.BoundedThreadPool$

I'm not sure what I should attempt next.

Server is 1.6.6, BlueBox is 1.0.5.

Startup logs show no errors.
User avatar
Site Admin
Posts: 21590
Joined: 21 Mar 2005, 09:50
Location: Italy

Postby Lapo » 05 Apr 2010, 17:08

Make sure that the <ServerIP> setting in your config.xml is set as this:

Code: Select all


Also check your file and make sure it has this line:

Code: Select all

...addicted to flash games
Posts: 4
Joined: 02 Apr 2010, 16:38

Postby jarruda » 05 Apr 2010, 17:19

Lapo wrote:Make sure that the <ServerIP> setting in your config.xml is set as this:

Code: Select all


This seems to have done the trick. The docs say "It's the physical IP address used by the server. By default, since version 1.5.9, the server binds all the available IP addresses, so you don't need to specify an address."

So I tried everything from leaving the tags empty, using the external IP, and, which was the default, all causing different errors. =)

Thanks for the response.

Return to “BlueBox”

Who is online

Users browsing this forum: No registered users and 2 guests