TypeError: Error #1091: XML parser failure: Unterminated CDA

Submit all your BlueBox related questions or report a bug here!

Moderators: Lapo, Bax

mikejdavison
Posts: 3
Joined: 24 Jun 2009, 20:15

TypeError: Error #1091: XML parser failure: Unterminated CDA

Postby mikejdavison » 17 Nov 2009, 07:24

Hi,

I'm trying to track this problem down. We're using SFS to talk to a mySql database. Until yesterday everything was working well enough, with this error mysteriously happening intermittently. Today however, we're getting this error 100% of the time.

In this case, one short JSON message has been sent to the Zone extension from the client, and a DB query result has been returned. After that two short messages are sent to the server, which has executed a number of querries and then sent two large responses back to the client. Those message don't arrive properly - that's when the error happens. I've gone through the entire database and ensured that there are no \n characters in there. Anything else I should look for? We're using version 1.6.1 of the client and 1.6.6 of the server.

cheers,
Mike
User avatar
Lapo
Site Admin
Posts: 21228
Joined: 21 Mar 2005, 09:50
Location: Italy

Postby Lapo » 18 Nov 2009, 20:35

Sorry,
were is this error fired? Server side?
Can you report here the log fragment with it?

Also if your data is in JSON it sounds weird that the error relates to XML ...
I would need more details if possible. Also I suppose this is happening with a client connected via BlueBox. Correct?
Lapo
--
gotoAndPlay()
...addicted to flash games
mikejdavison
Posts: 3
Joined: 24 Jun 2009, 20:15

Postby mikejdavison » 30 Nov 2009, 19:42

OK - that was stupid of me - this ended up in BlueBox by accident - it was meant to be in the main SFS forum. Anyhow - The error fires inside the SFS Client side code. The data being sent from the server is supposed to be JSON I think - I'm certainly sending JSON encoded stuff.

The client is AS3 using version 1.6.1 - there are no errors in the wrapper log to match the failure. It seems as if a message that arrives from the server to the client is malformed. It is now intermittent, and MAY have something to do with slow client connections.

Any ideas?
thanks,
Mike
User avatar
Lapo
Site Admin
Posts: 21228
Joined: 21 Mar 2005, 09:50
Location: Italy

Postby Lapo » 01 Dec 2009, 07:35

I don't really think that the server side message is formatted as JSON because the error clearly indicates that it is XML.
I will need to see the SmartFoxClient debug.
Make sure to turn on the SmartFoxClient.debug flag (set it to true) and run the client in Flash, this way you will be able to capture all incoming and outgoing data.
Lapo

--

gotoAndPlay()

...addicted to flash games

Return to “BlueBox”

Who is online

Users browsing this forum: No registered users and 1 guest