Configuration of SFS that runs BattleFarm

Submit all your BlueBox related questions or report a bug here!

Moderators: Lapo, Bax

CraigS83
Posts: 5
Joined: 29 Apr 2009, 14:56

Configuration of SFS that runs BattleFarm

Postby CraigS83 » 29 Apr 2009, 16:04

Hi there,

I am currently trying to get my SFS up and running and I
have been coming up against some difficulties!

When I try the Battle Farm example i am able to connect to the
game via the Force BlueBox option. I am currently connecting from
a university network, which at first i believed was the problem as some ports etc are restricted. However once i was able to play the Battle Farm game this theory went out the window!

I have my server running on virtual server (Ubuntu Server 64bit edition), it currently connects on port 80 as the documentation recommended. I have disabled all other processes on port 80 to ensure no conflicts. When I attempt to connect to my SFS bluehost using:

http://hostname:port/BlueBox/HttpBox.do

I am unable to connect to the BlueBox server, i was wondering how the server that is used for the Battle Farm example is set up, with regards to the bluehost port number, and the server port number???

kind regards,

Craig
User avatar
Lapo
Site Admin
Posts: 20426
Joined: 21 Mar 2005, 09:50
Location: Italy

Postby Lapo » 02 May 2009, 15:07

Hi,
When I attempt to connect to my SFS bluehost using:
http://hostname:port/BlueBox/HttpBox.do
I am unable to connect to the BlueBox server,

can you be more specific?
What problem do you get?
Maybe it's a simple config problem, if you point your browser to that address does it work correctly?

thanks
Lapo
--
gotoAndPlay()
...addicted to flash games
CraigS83
Posts: 5
Joined: 29 Apr 2009, 14:56

Postby CraigS83 » 08 May 2009, 13:07

Hey there lapo,

Many thanks for your reply, and apologies for my late response!

I have managed to connect to the bluebox page using -

http://HOSTIPADDRESS:80/BlueBox/HttpBox.do

This displays -

BlueBox
1.0.5
(c) 2007-2008 gotoAndPlay()

Then once i try to connect to the server using my game, with the
same HOSTIPADDRESS and a unopen port to force a bluebox connection
it fails, with two SFS DEBUG errors stating -

[SFS DEBUG] Http error creting http connection: System.Net.Sockets.SocketException: Connection timed out
at System.Net.Sockets.Socket.Connect (System.Net.EndPoint remote_end) [0x00000]

[SFS DEBUG] HttpError: Connection timed out
UnityEngine.Debug:Log(Object)

kind regards,

Craig
User avatar
Lapo
Site Admin
Posts: 20426
Joined: 21 Mar 2005, 09:50
Location: Italy

Postby Lapo » 09 May 2009, 11:15

So you are using the Unity API? Not Actionscript.
Please provide all the details otherwise it's easy to help :)
Which version of the C# API do you use?
Lapo

--

gotoAndPlay()

...addicted to flash games
CraigS83
Posts: 5
Joined: 29 Apr 2009, 14:56

Postby CraigS83 » 11 May 2009, 09:25

Hi there,

I went to find out the version of the API that I was using and noticed...

"The API provide full support to the SmartFoxServer features with the exclusion of the HTTP tunnelling capabilities."

Will there be a version of the .net Unity API for SFS that includes the HTTP tunneling??

cheers,

C
User avatar
Lapo
Site Admin
Posts: 20426
Joined: 21 Mar 2005, 09:50
Location: Italy

Postby Lapo » 11 May 2009, 12:20

The latest version actually does.
Please make sure to download the latest release here -> http://www.smartfoxserver.com/labs/API/
Also we're in the process of releasing another update soon.
Lapo

--

gotoAndPlay()

...addicted to flash games

Return to “BlueBox”

Who is online

Users browsing this forum: No registered users and 4 guests