Page 1 of 1

Bluebox working in debug but not in browser

Posted: 14 Feb 2008, 12:20
by preecep
I have blocked port 9339 on my local firewall.

I run the connection code locally in Flash and it connects via BlueBox ok.

When I run the swf from a website it does not connect. The site is on a different sub-domain than SFS.

I am wondering if this is a problem with:

Code: Select all"xmlsocket://");

As that call would be blocked?

Posted: 14 Feb 2008, 22:14
by Lapo
Make sure you have the same crossdomain policy that you send via socket also available in the root folder of the web server.


Posted: 14 Feb 2008, 23:05
by preecep
I commented out the loadPolicyFile and it now works on our test SFS as it has the crosspolicy file already on it :) But does not work on the production SFS. When I go to /BlueBox/ i get the following page:



Caused by:

java.lang.NoClassDefFoundError: it/gotoandplay/smartfoxserver/httpbox/util/SFSHandshake
at it.gotoandplay.smartfoxserver.httpbox.filter.SessionIDFilter.doFilter(
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(
at org.mortbay.jetty.servlet.ServletHandler.handle(
at org.mortbay.jetty.servlet.SessionHandler.handle(
at org.mortbay.jetty.handler.ContextHandler.handle(
at org.mortbay.jetty.webapp.WebAppContext.handle(
at org.mortbay.jetty.handler.ContextHandlerCollection.handle(
at org.mortbay.jetty.handler.HandlerCollection.handle(
at org.mortbay.jetty.handler.HandlerWrapper.handle(
at org.mortbay.jetty.Server.handle(
at org.mortbay.jetty.HttpConnection.handleRequest(
at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(
at org.mortbay.jetty.HttpParser.parseNext(
at org.mortbay.jetty.HttpParser.parseAvailable(
at org.mortbay.jetty.HttpConnection.handle(
at org.mortbay.thread.BoundedThreadPool$

Posted: 15 Feb 2008, 05:31
by Lapo
There is a missing class. You seem to have a non valid installation.
Check your versions: SFS should be at least 1.6.0 (recommended 1.6.1) and BlueBox 1.0.2 or higher

Posted: 16 Feb 2008, 00:09
by preecep
Wierd, I did a normal install for both. Fixed now thanks.