BlueBox server error

Submit all your BlueBox related questions or report a bug here!

Moderators: Lapo, Bax

Yu
Posts: 12
Joined: 14 Dec 2006, 17:03
Contact:

BlueBox server error

Postby Yu » 09 Jan 2008, 16:14

Hi,

I've installed the latest version of SmartFoxServer Pro 1.6. Everything works fine except the BlueBox part. I am getting the 500 server error when connecting to BlueBox server:

** Socket connection failed. Trying BlueBox **
[ Send ]: connect
Error opening URL "http://204.176.194.249:8080/BlueBox/HttpBox.do"


HTTP ERROR: 500

INTERNAL_SERVER_ERROR

RequestURI=/BlueBox/HttpBox.do
Caused by:

java.lang.NullPointerException
at it.gotoandplay.smartfoxserver.httpbox.filter.SessionIDFilter.doFilter(SessionIDFilter.java:110)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1089)
at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:365)
at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:712)
at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:211)
at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)
at org.mortbay.jetty.Server.handle(Server.java:285)
at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:502)
at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:821)
at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:513)
at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:208)
at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:378)
at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:368)
at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:442)

Powered by Jetty://


Here is my settings: (in config.xml, jetty.xml, and bluebox.properties)
sfs port: 443
BlueBox port: 8080

The odd thing is it's working on my local machine with these settings: (almost the same except sfs port to default)
sfs port: 9339
BlueBox port: 8080

When I access the URL: http://204.176.194.249:8080/BlueBox/, it tells me BlueBox successfully installed. Buy when I access URL: http://204.176.194.249:8080/BlueBox/HttpBox.do, it gives those server errors. I don't know what's going on, pls help!

Thanks,
Yu
User avatar
Lapo
Site Admin
Posts: 20896
Joined: 21 Mar 2005, 09:50
Location: Italy

Postby Lapo » 09 Jan 2008, 21:16

open the Server/bluebox.properties file and change the port value from 9339 to 443.
Let me know if it works
Lapo
--
gotoAndPlay()
...addicted to flash games
Yu
Posts: 12
Joined: 14 Dec 2006, 17:03
Contact:

Postby Yu » 14 Jan 2008, 15:20

I've already did that. That didn't work out. I finally figured out that in the config.xml file, instead of using the real IP address for the server, I need to use 127.0.0.1. That seems odd to me, but that solved the problem.

Yu
User avatar
Lapo
Site Admin
Posts: 20896
Joined: 21 Mar 2005, 09:50
Location: Italy

Postby Lapo » 14 Jan 2008, 16:09

A couple of questions:
can you confirm that you're using BlueBox version 1.0.2 ?
Could you post here the contents of the bluebox.properties found in the Server/ folder?

thanks
Lapo

--

gotoAndPlay()

...addicted to flash games

Return to “BlueBox”

Who is online

Users browsing this forum: No registered users and 2 guests