bluebox works in IE but not FireFox

Submit all your BlueBox related questions or report a bug here!

Moderators: Lapo, Bax

no-one
Posts: 35
Joined: 01 Sep 2007, 16:42

bluebox works in IE but not FireFox

Postby no-one » 18 Oct 2007, 14:33

hi

just want to let you know of a problem that i stumbled over.
when i try to use FireFox and connect trough bluebox it fails to connect, there's no timeout and not response at all. but when i use the same file in Internet explorer it works perfectly.

here's my game file if you want to test for yourself:
http://m0rkeulv.net/debug.html
patso
Posts: 380
Joined: 13 Nov 2006, 13:44
Location: Sofia, Bulgaria

Postby patso » 18 Oct 2007, 15:20

I've tested blue box with firefox and it works.

But your site doesn't work - only with IE
User avatar
Lapo
Site Admin
Posts: 20899
Joined: 21 Mar 2005, 09:50
Location: Italy

Postby Lapo » 18 Oct 2007, 16:32

The BlueBox is probably not the culprit here :)
I've checked the website with the following browsers:

FireFox Windows -> fail
FireFox MaxOS X -> fail
FireFox Ubuntu Linux -> fail
Safari MacOS X -> Ok
IE Windows -> Ok

Firefox is definitely not working! :shock: :P

Anyways by analyzing the traffic I can see that the BlueBox is never called when using Firefox... this is the symptom that the Flash Player never gets notified about the fact that a socket connection is not available.

I think we should introduce a configurable timeout in the client API to avoid these problems. I will do a couple of tests in the next days and provide some extra infos/help

Thanks for reporting.
Lapo
--
gotoAndPlay()
...addicted to flash games
Yu
Posts: 12
Joined: 14 Dec 2006, 17:03
Contact:

It's weird

Postby Yu » 30 Oct 2007, 15:02

Hi,

Here is the weird thing I found about this. If the BlueBox port is something else other than 80, for example use default 8080, then Firefox works fine.
But if you use port 80 for BlueBox, the flash client is not even make any request to the server when the xmlsocket connection is failed. I guess there must be something special for Firefox to handle port 80 in this case. I don't know if this is helpful for you, Lapo, to debug this.

Thanks,
Yu
User avatar
Lapo
Site Admin
Posts: 20899
Joined: 21 Mar 2005, 09:50
Location: Italy

Postby Lapo » 02 Nov 2007, 07:44

Thanks Yu,
I am going to inspect the issue soon.
Did you notice the problem using AS2 or AS3 ?
Lapo

--

gotoAndPlay()

...addicted to flash games
Yu
Posts: 12
Joined: 14 Dec 2006, 17:03
Contact:

Postby Yu » 02 Nov 2007, 19:28

I am using AS2.

Yu

Return to “BlueBox”

Who is online

Users browsing this forum: No registered users and 1 guest