[HTTP Send Request Error] BlueBox

Submit all your BlueBox related questions or report a bug here!

Moderators: Lapo, Bax

GalaxyDoomMaster
Posts: 10
Joined: 20 Mar 2018, 01:14

[HTTP Send Request Error] BlueBox

Postby GalaxyDoomMaster » 20 Mar 2018, 01:17

Warning: HTTP send request error, 12029: /BlueBox/HttpBox.do

So, when I press my 'multiplayer button' in my game, I sit on connecting for a while, when I go into my lobby the chat, list of players, or anything is not even showing or working.

I ran Flash in Debug mode and used mm.cfg to try and find out the error. I get that error you see above, and, also this error:

****************************************************************
Warning:
The room list is empty!
The client API cannot function properly until the room list is populated.
Please consult the documentation for more infos.
****************************************************************

Which this all was working before, but not anymore. How would I go about solving this?
User avatar
Lapo
Site Admin
Posts: 20385
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: [HTTP Send Request Error] BlueBox

Postby Lapo » 20 Mar 2018, 08:32

Hi,
we need more details to understand the problem.
Please take a look at the "Issue reporting guide" here:
viewtopic.php?f=18&t=16497

and let us know the details.
Thanks
Lapo
--
gotoAndPlay()
...addicted to flash games
GalaxyDoomMaster
Posts: 10
Joined: 20 Mar 2018, 01:14

Re: [HTTP Send Request Error] BlueBox

Postby GalaxyDoomMaster » 21 Mar 2018, 02:53

I apologize for not reading that first, I will do that for future posts.

However, I have solved my error, I apologize for that as well.

HOWEVER!!!!!! I do have another error. :?

My version is SmartFoxServer Basic, I am using this instead of 2X due to the fact the application I'm making was originally designed 9 years ago and used Basic 1.x

Here is some of the source code in my Flash: https://pastebin.com/khehLgd9

My Config.xml file: https://pastebin.com/Wx6jKLw6

My config.xml is a bit messy because I was trying to confirm the <extensions> tag was working, I'm not entirely sure if I'm doing this right.

My server console is giving out a 'unrecognized extension name: [ exRoom2 ] !

How would I go about solving this? And this isn't the entireity of the source code, just a snippit out of the code that actually references exRoom2 at all.

For those with the issue originally, I solved it by using the wrong version of SmartFoxServer, whoops. Thanks Mr Admin! You've been active here for a long time, I appreciate your duty. :)
User avatar
Lapo
Site Admin
Posts: 20385
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: [HTTP Send Request Error] BlueBox

Postby Lapo » 21 Mar 2018, 17:09

My config.xml is a bit messy because I was trying to confirm the <extensions> tag was working, I'm not entirely sure if I'm doing this right.

If the config doesn't work you will see XML errors when the server starts up. Did you check the logs?

My server console is giving out a 'unrecognized extension name: [ exRoom2 ] !

It would help to see the stack trace of the error as it provides more details.

Code: Select all

How would I go about solving this? And this isn't the entireity of the source code, just a snippit out of the code that actually references exRoom2 at all.

Well, there's a lot of code and we can't review all that in this forum, sorry.
I think the best idea is to see the complete transcript of the error and see what the problem might be. From your description it seems like a client is invoking an Extension that is not found.

Can you reproduce this at will?

Thanks
Lapo

--

gotoAndPlay()

...addicted to flash games
GalaxyDoomMaster
Posts: 10
Joined: 20 Mar 2018, 01:14

Re: [HTTP Send Request Error] BlueBox

Postby GalaxyDoomMaster » 21 Mar 2018, 21:21

The configuration is not giving me any XML errors. I am just trying to reference an extension, I don't even have the extension right now, this is an old project. I will have to make it, but the console gives me an error that showcases I can't even find the extension in the first place.

Sorry, and the error is quite tiny, it's just: (this was taken from log file)

Code: Select all

it.gotoandplay.smartfoxserver.exceptions.MissingExtensionException: Unrecognized extension name: [ exRoom2 ]!
2018/03/21 14:05:39.412 - [ WARNING ] [id: 12] (ExtensionHandler.processEvent):


I have it in my XML though so I don't know why this is coming up as unrecognized extension.

Ignoring that for a moment, I don't think the issue I was having was because of that. When I click on a building to build it, then that error comes up and the building doesn't play in a multiplayer match. This is how it is reproduced.

But the other issue I was having which I thought was because of this was that when me and another user were to make a multiplayer game, we ended out that the players could see each other in the playerlist, they could chat with one another, but when selecting players on each others teams, the host could not see anything update, but the other users who joined the lobby can. And when the host starts the server, it ends out with him not joining the game, just sitting at the same menu while other players played.

Code for lobby creation and such: https://pastebin.com/fsDYbFyn (should be not as much code, sorry for last time. :( )

In the code I have also ran you through it with text messages explaining you roughly what the code does and such, a lot of code has been removed for your ease!

Screenshots:

Image -- It says 'None' when there are users there. He can see it, but since I Am the host I can't, why? :(

Image -- When a user tries to build a building in a Multiplayer match.
User avatar
Lapo
Site Admin
Posts: 20385
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: [HTTP Send Request Error] BlueBox

Postby Lapo » 22 Mar 2018, 09:11

GalaxyDoomMaster wrote:The configuration is not giving me any XML errors. I am just trying to reference an extension, I don't even have the extension right now, this is an old project. I will have to make it, but the console gives me an error that showcases I can't even find the extension in the first place.

Sorry, I don't understand.
You said you "don't have the extension"... and you "will gave to make it".

If the extension is not deployed in the server you can't invoke it... this should be obvious... so I am confused :?:
Lapo

--

gotoAndPlay()

...addicted to flash games
GalaxyDoomMaster
Posts: 10
Joined: 20 Mar 2018, 01:14

Re: [HTTP Send Request Error] BlueBox

Postby GalaxyDoomMaster » 22 Mar 2018, 21:17

Haha, sorry, I know I don't have the extension file, but the console doesn't even recognize the name of the extension in the XML. Meaning even if I had the .as file, it wouldn't even load.

"ExRoom2" is an unrecognized extension, meaning it doesn't even know what it is, so in the XML I told it the extension name and file to look for, but it doesn't even recognize the name I put in there, am I using the <extension> tag incorrectly? I have the .as file now.
User avatar
Lapo
Site Admin
Posts: 20385
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: [HTTP Send Request Error] BlueBox

Postby Lapo » 23 Mar 2018, 09:14

GalaxyDoomMaster wrote:Haha, sorry, I know I don't have the extension file, but the console doesn't even recognize the name of the extension in the XML. Meaning even if I had the .as file, it wouldn't even load.

You must have the file.
You can't define an Extension that doesn't load anything (or a file that doesn't exits). You will get an error at boot time if you do so and therefore any subsequent calls to such extensions will cause errors.

In your code you have this:

Code: Select all

          roomObj = new Object();
            roomObj.name = r;
            roomObj.maxUsers = 4;
            roomObj.maxSpectators = 4;
            roomObj.isGame = true;
            roomObj.isTemp = true;
            xt = {};
            xt.name = "exRoom2";
            xt.script = "colonyExRoom.as";
            roomObj.extension = xt;
            fox.createRoom(roomObj);
            ROOT.auth = true;

which creates a Room and attaches an Extension to it which must be located at <SFSInstallFolder>/sfsExtension/colonyExRoom.as
Does this file exist under that folder?

Thanks
Lapo

--

gotoAndPlay()

...addicted to flash games
GalaxyDoomMaster
Posts: 10
Joined: 20 Mar 2018, 01:14

Re: [HTTP Send Request Error] BlueBox

Postby GalaxyDoomMaster » 28 Mar 2018, 05:41

Apologies, I didn't really you must have the 'Pro' version of SmartFoxServer for extensions to work, da-doi.

Thanks for the help anyway :lol:
User avatar
Lapo
Site Admin
Posts: 20385
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: [HTTP Send Request Error] BlueBox

Postby Lapo » 28 Mar 2018, 08:02

Ah yes. SFS Basic does not support server side code.

Cheers
Lapo

--

gotoAndPlay()

...addicted to flash games

Return to “BlueBox”

Who is online

Users browsing this forum: No registered users and 1 guest