Support for older JavaScript API in SmartFoxServer 2X version v2.17

Post here your questions about the HTML5 / JavaScript for SFS2X

Moderators: Lapo, Bax

andreynpetrov
Posts: 1
Joined: 03 Apr 2021, 15:13

Support for older JavaScript API in SmartFoxServer 2X version v2.17

Postby andreynpetrov » 03 Apr 2021, 15:29

Hi.

I have nodejs application with legacy JavaScript client API lib.

Is it still compatible with SmartFoxServer 2X version v2.17?

There is no "Use WS binary protocol" switch in AdminTool > Server Settings > Web server.

I tried to disable binary protocol in server.xml and change port to 8080 on client, but no luck.

Regards
Andrey
User avatar
Lapo
Site Admin
Posts: 21926
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: Support for older JavaScript API in SmartFoxServer 2X version v2.17

Postby Lapo » 05 Apr 2021, 09:54

Hi,
no the old legacy protocol was dropped since SFS2X v2.14.0.

Best regards
Lapo
--
gotoAndPlay()
...addicted to flash games

Return to “SFS2X HTML5 / JavaScript API”

Who is online

Users browsing this forum: No registered users and 3 guests