[[ NEW ]] FPS Demo!

Post here your questions about the Unity / .Net / Mono / Windows 8 / Windows Phone 8 API for SFS2X

Moderators: Lapo, Bax

ThomasLund
Posts: 1297
Joined: 14 Mar 2008, 07:52
Location: Sweden

Postby ThomasLund » 03 Dec 2010, 06:51

Did you upgrade the dll with the one I posted right before your message?

The exception text is caught - and is purely debug info - but could hint at you either not having the latest API dll. Additionally - several people have reported needing to manually allowing UDP on port 9933 on Windows.

/T
belltzaser
Posts: 5
Joined: 03 Dec 2010, 06:39

Postby belltzaser » 03 Dec 2010, 07:35

Hi mate,

I feel like an idiot. I didnt restart the SFS server after copying the jar file to the extension folder as per your document. Its working now!

As per your new DLL, works so far. I can run multiple times and quit Unity, even from my Netbook.

@Pax, make sure you copy the extensions JAR file to the smartfox server and restart the service.

Best regards
ThomasLund
Posts: 1297
Joined: 14 Mar 2008, 07:52
Location: Sweden

Postby ThomasLund » 03 Dec 2010, 07:46

Super duper!!! Just happy it works.

I'll get to finish up the logout bug + documentation very soon. Have a big deadline this weekend (might spill into next). Then there is time for finishing this baby up

/Thomas
dr-mad
Posts: 22
Joined: 09 Aug 2010, 16:29
Location: Netherlands - rotterdam

Postby dr-mad » 06 Dec 2010, 18:43

hi thomas i just test your .dll and it works a bit i can start the game and quit but in the editor if i change to another scene after i quit and the go to the lobby scene and try to start the game it freeze aggain

i never had problems with the udp i set 2 ports on my router 1 for each function

but i got olso a trange thing

if i try to put in my ip adress so it connect to my own ip then it wont load and the same ip was set for the sfs1.x and there it works well i find this strange becuase i know i set the good ip adress but it wont load and cant recieve a connection


but this are some bugs i found and just a ingame bug is

that if i look up then the other players dont see that im looking up they see me facing straight forward

just let you know this ;)

great work so far thanks
ThomasLund
Posts: 1297
Joined: 14 Mar 2008, 07:52
Location: Sweden

Postby ThomasLund » 07 Dec 2010, 11:14

I am going to finish up the documentation now as well as the logout bug.

Did anyone notice other issues?

The missing look animation is known, but not a bug. Decided not to sync that for the example. So thats left to the reader to implement :-)

/Thomas
3thamthmy
Posts: 5
Joined: 11 Dec 2010, 00:54
Location: Tunisia
Contact:

Postby 3thamthmy » 11 Dec 2010, 01:49

OMG .. i got crazy , it does not working with me ,

the UDP problem !! i'am using XP pack 3.

i did everything , i closed the windows Firewall .. nothing changed.

please help.
appels
Posts: 464
Joined: 28 Jul 2010, 02:12
Contact:

Postby appels » 11 Dec 2010, 04:39

3thamthmy wrote:OMG .. i got crazy , it does not working with me ,

the UDP problem !! i'am using XP pack 3.

i did everything , i closed the windows Firewall .. nothing changed.

please help.


the UDP has allways worked in all dll's that have been posted. if it doesn't then you probably have not added the UDP ports to the server or they are blocked by a firewall.
ThomasLund
Posts: 1297
Joined: 14 Mar 2008, 07:52
Location: Sweden

Postby ThomasLund » 11 Dec 2010, 09:28

Yeh - most likely you forgot to add the UDP listening port to the server configuration. Try to read the pdf document that comes with the demo on how to do that

/T
spencergong2
Posts: 8
Joined: 11 Dec 2010, 13:29

Postby spencergong2 » 11 Dec 2010, 13:39

I add the UDP listening port, disable firewall, patch new dll, It got error.

UDP error:
UnityEngine.Debug:Log(Object)
LobbyGUI:OnUdpInit(BaseEvent) (at Assets\Lobby\Scripts\LobbyGUI.cs:141)
Sfs2X.Core.EventDispatcher:DispatchEvent(BaseEvent)
Sfs2X.SmartFox:ProcessEvents()
LobbyGUI:FixedUpdate() (at Assets\Lobby\Scripts\LobbyGUI.cs:83)

SFS DEBUG] UDPSocketLayer: General error reading data from socket: Object reference not set to an instance of an object at System.Net.Sockets.UdpClient.Receive (System.Net.IPEndPoint& remoteEP) [0x00000]
at Sfs2X.Core.Sockets.UDPSocketLayer.Read () [0x00000]

[SFS DEBUG] Unexpected UDP I/O Error. General error reading data from socket: Object reference not set to an instance of an object at System.Net.Sockets.UdpClient.Receive (System.Net.IPEndPoint& remoteEP) [0x00000]
at Sfs2X.Core.Sockets.UDPSocketLayer.Read () [0x00000] [NotSocket]

In the console:

user doest not exist ,id 28
ThomasLund
Posts: 1297
Joined: 14 Mar 2008, 07:52
Location: Sweden

Postby ThomasLund » 11 Dec 2010, 13:49

I have no problems at all with UDP once you have enabled it on the server and restarted it. Neither local not running the server remote.

And I use this in several projects.

So it must be something local for you guys. Firewall, forgotten to turn on UDP, listening on the wrong ip, anti-virus somehow interfering with UDP trafic.

The connection and operation of UDP has worked from day 1 - just the shutdown part was buggy.

/Thomas
appels
Posts: 464
Joined: 28 Jul 2010, 02:12
Contact:

Postby appels » 11 Dec 2010, 13:59

yep, udp runs fine, local and remote. no problem.
spencergong2
Posts: 8
Joined: 11 Dec 2010, 13:29

It works.

Postby spencergong2 » 11 Dec 2010, 22:04

After restarting computer,it works.
Thanks for all help.
spencergong2
Posts: 8
Joined: 11 Dec 2010, 13:29

Postby spencergong2 » 11 Dec 2010, 23:46

Hi ThomasLund,

Is it possible for you uploading java source code of SFSTris2x.jar with client example of unity+SFS2x?

Thanks for your help.
Spencer
ThomasLund
Posts: 1297
Joined: 14 Mar 2008, 07:52
Location: Sweden

Postby ThomasLund » 12 Dec 2010, 07:10

Easy to help you on that one - its already on your harddrive :-D

Client/Unity/Examples/SFS2X-TrisGame has the client part
Client/SFSTris2X-Extension-src.zip has the server part

/Thomas
3thamthmy
Posts: 5
Joined: 11 Dec 2010, 00:54
Location: Tunisia
Contact:

Postby 3thamthmy » 13 Dec 2010, 01:32

oopps ! sorry it's working now ,

i added my local IP adress 192.168.1.100 to the admin console with UDP.

it's working without restarting .

all fine , your new DLL in working perfect .

Amazing job .. powerful foxserver.

Return to “SFS2X C# API”

Who is online

Users browsing this forum: No registered users and 7 guests