SetReconnectionSeconds(int);

Post here your questions about the Unity / .Net / Mono / Windows 8 / Windows Phone 8 API for SFS2X

Moderators: Lapo, Bax

appels
Posts: 464
Joined: 28 Jul 2010, 02:12
Contact:

SetReconnectionSeconds(int);

Postby appels » 04 Apr 2013, 19:17

Hi,

I'm trying to set the reconnect seconds on the Unity client but it's not affecting the server.
In the server console, Runtime user settings, the value is set to 0.
Also on the client when I call GetReconnectionSeconds(), the value is set to 0.
I have tried to set it at different moments during the login phase but it never changes.
I'm on 2.6.0 by the way.
appels
Posts: 464
Joined: 28 Jul 2010, 02:12
Contact:

Re: SetReconnectionSeconds(int);

Postby appels » 04 Apr 2013, 21:56

The reconnection works when I call the method after udp init but it doesn't show in the web console.
appels
Posts: 464
Joined: 28 Jul 2010, 02:12
Contact:

Re: SetReconnectionSeconds(int);

Postby appels » 05 Apr 2013, 08:13

hmm getting wierd results...
When I use the api that's packed with the server ( api version 1.0.5 ), the reconnection works but I don't see any debug on it.
When I use the 1.2.0, I get all debug messages but the reconnection doesn't work, the session never gets matched on the server.
I can send the project if needed.
User avatar
Lapo
Site Admin
Posts: 20761
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: SetReconnectionSeconds(int);

Postby Lapo » 08 Apr 2013, 09:54

The reconnection seconds parameter depends exclusively on the server-side configuration.
Do not attempt to change it from client side.

If you want to activate the HRC+ you need to open the AdminTool > ZoneConfigurator and set the Reconnection Time from there.
The restart SFS2X and you're done.

Take a look here too:
http://docs2x.smartfoxserver.com/Gettin ... n-hrc-plus
Lapo
--
gotoAndPlay()
...addicted to flash games

Return to “SFS2X C# API”

Who is online

Users browsing this forum: No registered users and 3 guests