Unity 3.4 / SFS2x RC1 Tutorial Issues

Post here your questions about the Unity / .Net / Mono / Windows 8 / Windows Phone 8 API for SFS2X

Moderators: Lapo, Bax

alaindumdum
Posts: 17
Joined: 09 Oct 2011, 18:29

Postby alaindumdum » 12 Oct 2011, 13:43

that rocks !

http://mixed3d.net/unity/a/SFS2X-LobbyPlayer.html

Thanx for your patience

I go to sfsFPS stuff now...
alaindumdum
Posts: 17
Joined: 09 Oct 2011, 18:29

Postby alaindumdum » 12 Oct 2011, 14:32

still

Code: Select all

Debug.Log("On Connection callback got: " + success + " (error : <" + error + ">)");

on the editor with the stuff UnityFPSDemo

and my server's log
says

Code: Select all

12 Oct 2011 17:39:55,299 INFO  [SocketReader] bitswarm.core.SocketReader     - Socket closed: java.nio.channels.SocketChannel[closed]
12 Oct 2011 17:39:55,299 INFO  [Scheduler1-thread-1] bitswarm.sessions.DefaultSessionManager     - Session removed: { Id: 81, Type: DEFAULT, Logged: No, IP: 83.205.169.219:2859 }


any tips ? please
alaindumdum
Posts: 17
Joined: 09 Oct 2011, 18:29

Postby alaindumdum » 12 Oct 2011, 18:18

alaindumdum wrote:still

Code: Select all

Debug.Log("On Connection callback got: " + success + " (error : <" + error + ">)");

on the editor with the stuff UnityFPSDemo

and my server's log
says

Code: Select all

12 Oct 2011 17:39:55,299 INFO  [SocketReader] bitswarm.core.SocketReader     - Socket closed: java.nio.channels.SocketChannel[closed]
12 Oct 2011 17:39:55,299 INFO  [Scheduler1-thread-1] bitswarm.sessions.DefaultSessionManager     - Session removed: { Id: 81, Type: DEFAULT, Logged: No, IP: 83.205.169.219:2859 }


any tips ? please


BTW if I dont get that ,
I will may be use the connector , that seems working
http://mixed3d.net/unity/connectorPlayer.html

***********
reedit

hum ,
that seems NOT now :(


re reedit :

or may be yes now !!

pffffffffffff :(
**************


and will try to build inside my 3d world from scratch , and adding a chat .
But I would prefer to start from UnityFPSDemo.

( indeed my aim is just to have some of my poor 3d worlds with a chat ,
all that , LOL for 2 ou 3 friends :)

ps , one thing is sure is that the "security.Prefecht" tip saved my day(S),
my months :(

But I have still a long way to Tipperary .....
alaindumdum
Posts: 17
Joined: 09 Oct 2011, 18:29

Postby alaindumdum » 14 Oct 2011, 20:44

I am still very lost with UnityFPSDemo

the gamelist shows no game :(

So I used in a crappy way the SFS2X-Lobby ,
to get a chat AND a test world in , made from scratch

http://mixed3d.free.fr/unity3d/smartfox ... layer.html

Image

Is the chat working ? if someone has 2 seconds to test , thank you...

BTW I would prefer get some more help on UnityFPSDemo.

I dont know what I miss there ...

what sort of logs you need to help me ???
appels
Posts: 464
Joined: 28 Jul 2010, 02:12
Contact:

Postby appels » 15 Oct 2011, 00:07

It seems to work, i get back my chat message.
Some free advice, since your learning how SFS2 works with Unity, start without any assets. Just use a floor and some cubes or the FPSController from Unity. Your just making the process to learn SFS harder by adding stuff thats not realy needed.
Start with connect, spawn your players, add chat and then build up.
I found that the best way to learn it. Anyway, just some advice :)
alaindumdum
Posts: 17
Joined: 09 Oct 2011, 18:29

Postby alaindumdum » 15 Oct 2011, 12:55

Well, dear appels, learning , it is what I do since 2010 , LOL :

http://mixed3d.free.fr/spip/?cat=37

I guess that networking is more for programers than for stupid art teachers , LOL

But may be you are right , but your way seems harder for me ..huumm

Anyways, thank you,
and as I cant succeed starting from FPSDemo,
I continued my crappy way from SFS2X-Lobby.

Now I used a world I made that summer and added the LobbyGUI.cs

In a way it is "funny" to have the chat as a HUD.....

May be that works , I must find a friend to test it.

But I got it at home :

?Image

Could I clean the script ? and how ?

the editor says

Code: Select all

Assets/Scripts/LobbyGUI.cs(36,27): warning CS0414:
The private field `LobbyGUI.roomStrings' is assigned but its value is never used



I am afraid to delete something useful ....

Could you tell me what to change , smartfolks ? Thanx in advance.

The script I use now ( and modified ) is archived here , take a look please , if time:

http://mixed3d.free.fr/unity3d/smartfox/LobbyGUI.cs

The test is here :

http://mixed3d.free.fr/unity3d/smartfox ... layer.html

Last question :

I have a disconection after a few time ,
I have read somewhere days ago something to increase the delay ,
but I cant retrieve that .

What is the trick please ?
alaindumdum
Posts: 17
Joined: 09 Oct 2011, 18:29

Postby alaindumdum » 15 Oct 2011, 18:08

thats Ok for the moment ,
I got a friend to test,
that works ,
I have still the questions above ,
but ....:)
alaindumdum
Posts: 17
Joined: 09 Oct 2011, 18:29

Postby alaindumdum » 16 Oct 2011, 07:37

Well , I think I found the trick :
I increased the user idletime in the admin tool from 120 to 1200 .

I cleaned too the cs scritpt and made another test :

http://mixed3d.free.fr/unity3d/smartfox ... layer.html

So thank you appels, Thomas and bax..

Btw I would prefer to start from FPSDemo , I wonder what I dont understand in :(
alaindumdum
Posts: 17
Joined: 09 Oct 2011, 18:29

Postby alaindumdum » 24 Oct 2011, 19:14

hello ,
I come back :)

I was a bit happy with my crappy chat , getting it from SFS2X Lobby .

I made 3 experiments and that works .

Then , I tried to do the same way ,
using worlds I made months ago,
and adding in
the same scripts ,
the same plugins
as I show here

http://alaindumenieu.pagesperso-orange. ... 201011.htm

BUT ! now , when I do that ,

I only get the "login" in the editor ,
and can't get the chat , and then that disconnect soon ....

What I miss ???????

Return to “SFS2X C# API”

Who is online

Users browsing this forum: No registered users and 10 guests