SFS2x disconnect and no event fired in as3

Post here your questions about the Flash / Flex / Air API for SFS2X

Moderators: Lapo, Bax

clam61
Posts: 125
Joined: 12 Sep 2007, 02:00

SFS2x disconnect and no event fired in as3

Postby clam61 » 19 Dec 2013, 08:24

Sometimes SFS2x drops a connection to the client (it is not a result of a timeout as I have the client ping the server to avoid that), but the client does not received a CONNECTION_LOST event ever.

Anyone else have this issue?
User avatar
Bax
Site Admin
Posts: 4481
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Re: SFS2x disconnect and no event fired in as3

Postby Bax » 19 Dec 2013, 09:07

How do you know that the connection was dropped if you don't receive the connection lost event?
Paolo Bax
The SmartFoxServer Team
clam61
Posts: 125
Joined: 12 Sep 2007, 02:00

Re: SFS2x disconnect and no event fired in as3

Postby clam61 » 21 Dec 2013, 22:07

Good question. Because on the SFSAdmin I can see the # of users online and also from logging in as other users I can see that they are listed as offline in my UI.
User avatar
Bax
Site Admin
Posts: 4481
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Re: SFS2x disconnect and no event fired in as3

Postby Bax » 22 Dec 2013, 11:26

Something else must be going on, because the server doesn't drop connections for no reason. Either the user is disconnected for being idle, or there's a network issue.
For example if you break the connection by unplugging the network table, you won't receive the disconnection event until a timeout at operating system level triggers.
In order to be able to help we need more informations for you. What steps do you take in your application?
Paolo Bax
The SmartFoxServer Team
User avatar
Paul
Posts: 4
Joined: 24 Jan 2014, 09:38
Location: Russian Federation
Contact:

Re: SFS2x disconnect and no event fired in as3

Postby Paul » 24 Jan 2014, 11:13

There was a similar problem when connected via BlueBox.
CONNECTION_LOST event occurs about 5-8 minutes after the session has been destroyed and the server has been called disconnectUser.
Maybe we are doing something wrong?
Question: how much to programmers that would replace the bulb?
Answer: no programmer! This hardware problem ...
User avatar
Lapo
Site Admin
Posts: 21091
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: SFS2x disconnect and no event fired in as3

Postby Lapo » 24 Jan 2014, 16:00

Paul, it is not clear. Is your post related to the same issue in the opening post or are you just saying that a similar issue occurred to you?
Is it something reproducible at will? If so how?
Lapo
--
gotoAndPlay()
...addicted to flash games
User avatar
Paul
Posts: 4
Joined: 24 Jan 2014, 09:38
Location: Russian Federation
Contact:

Re: SFS2x disconnect and no event fired in as3

Postby Paul » 24 Jan 2014, 16:26

Lapo wrote:Paul, it is not clear. Is your post related to the same issue in the opening post or are you just saying that a similar issue occurred to you?
Is it something reproducible at will? If so how?


Maybe it's related to the theme, but not sure.
Play this problem can be quite simple.
I have a problem arose in the case originally started the game in Google Chrome, and then parallel to run the game in Firefox, but under the same account (login). Thus always useBlueBox = true. If you believe the documentation session game GoogleChrome should close and the game should receive the event CONNECTION_LOST, but the event comes after almost 8 minutes! Maybe I'm doing something wrong or is it quite normal?
Question: how much to programmers that would replace the bulb?
Answer: no programmer! This hardware problem ...
User avatar
Lapo
Site Admin
Posts: 21091
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: SFS2x disconnect and no event fired in as3

Postby Lapo » 24 Jan 2014, 17:45

I don't understand.
If you are already logged in Chrome how can you login also with Firefox? In any case the former user will be kicked out.

My question is not how did you do it, but can you do it 10-20 times and always obtain the same problem? I wouldn't expect that, but if you can then you could point me to the game. If it is live, as it seems, we can test from here and see if does the same.

Thanks
Lapo

--

gotoAndPlay()

...addicted to flash games
User avatar
Paul
Posts: 4
Joined: 24 Jan 2014, 09:38
Location: Russian Federation
Contact:

Re: SFS2x disconnect and no event fired in as3

Postby Paul » 27 Jan 2014, 09:15

The point is not that open multiple windows with the game, but the fact that the client is connected to SmartFoxServer using BlueBox CONNECTION_LOST receives an event long overdue, if the session and connection break on the server.
Question: how much to programmers that would replace the bulb?
Answer: no programmer! This hardware problem ...
User avatar
Lapo
Site Admin
Posts: 21091
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: SFS2x disconnect and no event fired in as3

Postby Lapo » 27 Jan 2014, 14:56

Technically there is no persistent connection between client and server via the BlueBox. Since the BB uses HTTP tunneling the server can't detect a physical disconnection and assumes that the client has stopped his communication after he's stopped pinging for a certain amount of time.

We'll test the scenario and see if we can reproduce it.
Thanks
Lapo

--

gotoAndPlay()

...addicted to flash games

Return to “SFS2X ActionScript 3 API”

Who is online

Users browsing this forum: No registered users and 4 guests