SWC problem: Version required to extract entry not supported

Post here your questions about the Flash / Flex / Air API for SFS2X

Moderators: Lapo, Bax

Cpt Pete
Posts: 9
Joined: 01 Mar 2012, 11:34

SWC problem: Version required to extract entry not supported

Postby Cpt Pete » 01 Mar 2012, 11:52

Anyone else getting the message "Version required to extract entry not supported" when trying to browse the SWC contents?

I'm using FlashDevelop so it might be a problem with that but from what I can gather it maybe a problem with the header file for the swc.

Because FlashDevelop can't read the file it can't provide code completion / validation for any of the SmartFoxServer classes. However, The FlexSDK seems to be happy to compile it as it works at runtime.

I'm using the SFS2X_API_AS3_v1.0.3 swc. Can anyone confirm code completion works in FlashBuilder with this swc?

Cheers
User avatar
Bax
Site Admin
Posts: 4517
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Re: SWC problem: Version required to extract entry not suppo

Postby Bax » 02 Mar 2012, 09:14

Yes, code completion in Flash Builder works fine.
I'm not familiar with Flash Develop, so I can't say why the SWC is not working there.
Paolo Bax
The SmartFoxServer Team
secret007
Posts: 58
Joined: 29 May 2009, 06:27

Re: SWC problem: Version required to extract entry not suppo

Postby secret007 » 06 Mar 2012, 07:20

Yes, same problem here i was using Flash Develop before, but when i update the new patch of swc file, flash develop no longer showing code completion but its working fine in Flash Builder thats why i switched to FB for the time being lol ;)
======================================================
Choose a job of your choice and you will never have to work in life !!!
User avatar
Bax
Site Admin
Posts: 4517
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Re: SWC problem: Version required to extract entry not suppo

Postby Bax » 06 Mar 2012, 09:11

Could this depend on the fact that the latest SWC contains documentation that FB shows during the code completion?
You can try removing it: open the sec with a zip software and remove the "docs" folder.
Paolo Bax
The SmartFoxServer Team
udikantz
Posts: 153
Joined: 24 Sep 2009, 09:36

Re: SWC problem: Version required to extract entry not suppo

Postby udikantz » 28 Mar 2012, 12:47

Any plans on fixing this version for flash develop, it removes the intellisense make it impossible to code.
diwip games - co founder & CPO.

http://www.diwip.com
User avatar
rjgtav
Posts: 2813
Joined: 19 Apr 2009, 11:31
Location: Lisbon, Portugal

Re: SWC problem: Version required to extract entry not suppo

Postby rjgtav » 28 Mar 2012, 20:28

Hi.
There's already a fix for the problem. Check here on the FlashDevelop forums.
Basically you have to:
1. Change the file extension from swc to zip.
2. Unzip its contents
3. Zip the content again
4. Change the extension of the file back to swc.

It looks like the team used a different ZIP encoding when creating the swc.
Skills: SFS Pro, SFS2X, AS2.0/AS3.0, Java, HTML5/CSS3/JS, C#
Portfolio: https://rjgtav.wordpress.com/
SFS Tutorials: http://sfs-tutor.blogspot.com/ - Discontinued. Some examples may be bugged.
kalani96746
Posts: 6
Joined: 21 Jun 2008, 17:24

Re: SWC problem: Version required to extract entry not suppo

Postby kalani96746 » 31 May 2012, 18:58

I was about to say.... I use a mac and when attempting to unzip it would unzip the zip first then unzip the swc automatically and I was left with a folder rather than a swc...wtf? I run a VM Windows box so I tried it there so I could get a .swc and I got the .swc and it works for compiling but the .swc didn't work with FlashDevelop and its codehinting...FlashDevelop can't read it (i.e: Error: Version required to extract this entry not supported (788)) when expanding in Project View. After renaming (to .zip), unzipping, rezipping, renaming (back to .swc), and spinning around in a circle while tapping on my head and rubbing my belly I was able to get to work; not sure if the last step was necessary or not. Thanks!
User avatar
xLite
Posts: 106
Joined: 05 May 2010, 12:42

Re: SWC problem: Version required to extract entry not suppo

Postby xLite » 19 Feb 2013, 14:40

rjgtav wrote:Hi.
There's already a fix for the problem. Check here on the FlashDevelop forums.
Basically you have to:
1. Change the file extension from swc to zip.
2. Unzip its contents
3. Zip the content again
4. Change the extension of the file back to swc.

It looks like the team used a different ZIP encoding when creating the swc.



Just want to confirm that this worked perfectly using WinRAR, simply a weird zip encoding error on SFS's behalf.
User avatar
Lapo
Site Admin
Posts: 21596
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: SWC problem: Version required to extract entry not suppo

Postby Lapo » 03 Jan 2014, 17:57

Update: the problem is solved now. During the deployment phase we use a zip tool to add the documentation data inside the SWC which is possibly causing the issue. Substituting the tool has resolved the issue.

Thanks
Lapo
--
gotoAndPlay()
...addicted to flash games

Return to “SFS2X ActionScript 3 API”

Who is online

Users browsing this forum: No registered users and 3 guests