SFS2X-Standalone.exe Not working as intended?

Post here your questions about SFS2X. Here we discuss all server-side matters. For client API questions see the dedicated forums.

Moderators: Lapo, Bax

wadapav
Posts: 14
Joined: 29 Oct 2018, 11:00

SFS2X-Standalone.exe Not working as intended?

Postby wadapav » 29 Oct 2018, 11:05

Hi TO Community! I recently installed TamrielOnline client and server, but I'm having a bit of a hitch trying to load up the server. I have all the server files extracted into a folder, and when I launch the sfs2x-standalone.exe file (As per instructions on this subreddit) a CMD line opens, and what appears to be the program loading happens (Ascii art of SFX 2X Ready, saying its ready). After that though, a few more lines load and the program closes. I have found nothing that fixes this from the Elusive Conclusive guide yet, and I've tried re-downloading the files and creating firewall rules. I can provide anything needed to further diagnose the issue, so please ask if I haven't said enough here. Any help is appreciated, thanks!
Last edited by wadapav on 31 Oct 2018, 13:16, edited 1 time in total.
User avatar
Lapo
Site Admin
Posts: 21014
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: SFS2X-Standalone.exe Not working as intended?

Postby Lapo » 29 Oct 2018, 11:39

Hi,
just to be clear this is not the Tamriel Online community. We understand that TO uses SmartFoxServer 2X to host multiplayer games, however we don't know how the game is packaged and deployed or how it uses SmartFox exactly.

Regarding your specific problem: if sfs2x-standalone shuts down after booting there is probably a boot error. Check the logs under SFS2X/logs/smartfox.log and report what you have found to the Tamriel Online support. They should be able to help you better than us, because they have created the game.
Lapo
--
gotoAndPlay()
...addicted to flash games

Return to “SFS2X Questions”

Who is online

Users browsing this forum: No registered users and 18 guests