lost message problem

Post here your questions about SFS2X. Here we discuss all server-side matters. For client API questions see the dedicated forums.

Moderators: Lapo, Bax

aliko
Posts: 115
Joined: 09 Mar 2013, 16:26

lost message problem

Postby aliko » 07 Sep 2016, 15:45

Hello,

I'm sending this object to a player like below. (from server extention)
Sometimes one of my client (from 1500 players) cannot recieve this extenison message.
I'm sure that because I added a log to client for that to onExtensionResponse(evt:SFSEvent):void { (recieved msg...)
My client api is AS3.

Also when I looked client smartfox.log details, I saw that there is no any connection alert etc.

What will be the problem or how can I find it, can you help me please?
How can I be sure that client recieved my extension msg?

Best Regards,
Ali

Code: Select all

ISFSObject rtn = new SFSObject();
rtn.putUtfString("t", "tablename");
send("jtg", rtn, player);
User avatar
Lapo
Site Admin
Posts: 20378
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: lost message problem

Postby Lapo » 08 Sep 2016, 07:53

( Moved to the SFS2X Questions section )

Hi,
You're saying that for the client who doesn't receive the extension message there's no logging data about his connection? If that is the case, it also explains why he didn't receive the Extension message :)

But maybe I am misunderstanding this.

Also I am not sure how this is tested. You said you have ~1500 CCU, how do you check their logs... are these local clients?
Does this always happen to the same client? To more than one client?

Thanks
Lapo
--
gotoAndPlay()
...addicted to flash games
aliko
Posts: 115
Joined: 09 Mar 2013, 16:26

Re: lost message problem

Postby aliko » 08 Sep 2016, 09:06

Aha sorry :) I want to say there is no log about disconnection. He seems connected.

They are not local clients.
I added a function that sends an extesion msg to server when he recieve and extension message from server.
This happen not only same user, different users...


Code: Select all

   private function onExtensionResponse(evt:SFSEvent):void {
         var cmd : String = evt.params.cmd;
         sendCheckLog("I recieved this cmd:" + cmd);
         //doing other jobs regarding for cmd...
      }


public function sendCheckLog(log:String):void {
         var logObj:ISFSObject = new SFSObject();
         logObj.putUtfString("checklog", clientversion);
         logObj.putUtfString("log", log);
         sendExtRequest("pleaselog", logObj);
      }
User avatar
Lapo
Site Admin
Posts: 20378
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: lost message problem

Postby Lapo » 08 Sep 2016, 14:28

You should take a look at the AdminTool's Dashboard, bottom right corner, you should see the number of (outgoing) dropped messages.
Also can you tell me if those clients missing the message are connected via socket or BlueBox?

What version of SFS2X are you running by the way?

thanks
Lapo

--

gotoAndPlay()

...addicted to flash games
aliko
Posts: 115
Joined: 09 Mar 2013, 16:26

Re: lost message problem

Postby aliko » 08 Sep 2016, 14:54

They are connect via socket, I disabled Bluebox.

Server version : 2.11.1

Image
User avatar
Lapo
Site Admin
Posts: 20378
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: lost message problem

Postby Lapo » 09 Sep 2016, 09:55

It looks like the server has been running for quite sometime? What is the uptime?

The number of dropped packet is quite high but relative to the tot. amount of packets is less than 1% which is very good, considering that 5-10% is the average. This means only a tiny fraction of clients have had packet loss issues.

It is likely that the problem you are describing falls within those few cases. Dropped packets is due to connectivity issues from the client side and there's not much you can do about it. You can read more about it here:
http://docs2x.smartfoxserver.com/Gettin ... g#section4

In addition you could take a look at a series of optimization tips in this article:
http://smartfoxserver.com/blog/top-10-c ... he-plague/

In particular I recommend reading numbers 3,4,8 and 9, which are relevant to this case.

Finally if your game/app has a high packet rate, you may want to see if there are ways to optimize or reduce it. This is usually needed only for packet rates > 10pps. (packet per second)

Hope it helps
Lapo

--

gotoAndPlay()

...addicted to flash games
aliko
Posts: 115
Joined: 09 Mar 2013, 16:26

Re: lost message problem

Postby aliko » 10 Sep 2016, 13:23

Thank you very much for your detailed answer Lapo.
I will look for optimization to my codes.

My server uptime is 16:24:04 up 269 days, 21:27, 1 user, load average: 0.56, 0.50, 0.40

I think there is no problem on server. I need to optimize my codes .

Best regards,
ali

Return to “SFS2X Questions”

Who is online

Users browsing this forum: No registered users and 21 guests