Eclipse Debugging Issue

Post here your questions about SFS2X. Here we discuss all server-side matters. For client API questions see the dedicated forums.

Moderators: Lapo, Bax

Birch
Posts: 15
Joined: 06 Jun 2012, 07:42
Location: Sweden

Eclipse Debugging Issue

Postby Birch » 06 Jun 2012, 08:53

Hello!

I am having a quite strange problem when i'm trying to debug my server side extensions. I've added the three switches to JVM options and i can debug, sometimes. It seems like i can only debug after changing "suspend=n" to "suspend=y" or vice versa in the JVM options. When i can't debug, Eclipse gives me this message "Failed to connect to remote VM. Connection refused". I'm using SFS2x 2.0.1 Community Edition on a Mac if that matters, any ideas? :?

This might be unrelated but every time i manage to debug a new tab named "URLClassLoader$1.run() line: 202" opens in Eclipse. Which tells me "Source not found" and wants me to Edit the Source Lookup Path. Again, this might not be related but just wanted to give you as much info as possible.
User avatar
Lapo
Site Admin
Posts: 21639
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: Eclipse Debugging Issue

Postby Lapo » 06 Jun 2012, 15:06

With suspend = y the JVM suspends the execution until a debugger connects to the "debuggee" JVM. It shouldn't make a big difference.
Unfortunately I am not a big fan of Eclipse's debugger, especially due to the asynchronous and multithreaded nature of the Server. Maybe someone else has an insight on this?

As regards the other strange error I have no idea, but again stopping one thread as the others keep going may cause strange things to happen.
cheers
Lapo
--
gotoAndPlay()
...addicted to flash games
mani95lisa
Posts: 4
Joined: 06 Jun 2012, 08:42

Re: Eclipse Debugging Issue

Postby mani95lisa » 06 Jun 2012, 15:35

Hi, I have the same problem, have you fix it?
Birch
Posts: 15
Joined: 06 Jun 2012, 07:42
Location: Sweden

Re: Eclipse Debugging Issue

Postby Birch » 06 Jun 2012, 15:39

Nope :?

Return to “SFS2X Questions”

Who is online

Users browsing this forum: Baidu [Spider] and 20 guests