private messages received as ***

Post here your questions about SFS2X. Here we discuss all server-side matters. For client API questions see the dedicated forums.

Moderators: Lapo, Bax

mixart
Posts: 95
Joined: 08 Aug 2007, 20:32

private messages received as ***

Postby mixart » 05 May 2012, 12:25

Anyone know why when I send a private message, it is returned as asterisks?

[SFS - INFO] Object going out:
(short) a: 7
(sfs_object) p:
(utf_string) m: hi there
(byte) t: 1
(int) rc: 27

(byte) c: 0


Received as...

[SFS - INFO] GenericMessage { Message id: 7 }
{ Dump: }

(byte) t: 1
(int) r: -1
(int) u: 24
(utf_string) m: *** *****
User avatar
rjgtav
Posts: 2813
Joined: 19 Apr 2009, 11:31
Location: Lisbon, Portugal

Re: private messages received as ***

Postby rjgtav » 05 May 2012, 12:44

Hello.
Don't forget to disable the words filter for private messages in the General Tab of your Zone Configurator. Please also make sure that the words filter mode is set to BlackList.
Skills: SFS Pro, SFS2X, AS2.0/AS3.0, Java, HTML5/CSS3/JS, C#
Portfolio: https://rjgtav.wordpress.com/
SFS Tutorials: http://sfs-tutor.blogspot.com/ - Discontinued. Some examples may be bugged.
mixart
Posts: 95
Joined: 08 Aug 2007, 20:32

Re: private messages received as ***

Postby mixart » 05 May 2012, 17:26

Turning off "apply words filter to private messages" seemed to do the trick.

Seems like there might be a bug somewhere. I had all settings to default... "apply words to PM" was on (by default), but also my words filter and flood filter were both turned off, not active (by default). So even though I had words filter set to inactive but had set to "apply words filter to private messages" on, it was filtering everything.

If the words filter is inactive, it should not filter anything.

Can you repro?
User avatar
rjgtav
Posts: 2813
Joined: 19 Apr 2009, 11:31
Location: Lisbon, Portugal

Re: private messages received as ***

Postby rjgtav » 05 May 2012, 17:42

Yeah I can. That "bug" has been there for a while. Not sure if it is intended or not. Will check with the team. Thanks for reminding
Skills: SFS Pro, SFS2X, AS2.0/AS3.0, Java, HTML5/CSS3/JS, C#
Portfolio: https://rjgtav.wordpress.com/
SFS Tutorials: http://sfs-tutor.blogspot.com/ - Discontinued. Some examples may be bugged.
User avatar
Lapo
Site Admin
Posts: 21685
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: private messages received as ***

Postby Lapo » 07 May 2012, 16:39

I don't understand what bug we are talking about.
Can you please provide the exact settings of your zone as regards the word filtering?
By default theres's only one Zone in SFS2X --> BasicExamples and it doesn't filter any message.
Lapo
--
gotoAndPlay()
...addicted to flash games
User avatar
rjgtav
Posts: 2813
Joined: 19 Apr 2009, 11:31
Location: Lisbon, Portugal

Re: private messages received as ***

Postby rjgtav » 07 May 2012, 19:47

Hmm... It looks like I was running an older version of the server, for some reason. I can't reproduce it on the latest version

@mixart, can you please try updating the server to the latest version and enable the "apply words filter to private messages" setting and test again?
Skills: SFS Pro, SFS2X, AS2.0/AS3.0, Java, HTML5/CSS3/JS, C#
Portfolio: https://rjgtav.wordpress.com/
SFS Tutorials: http://sfs-tutor.blogspot.com/ - Discontinued. Some examples may be bugged.
itsmylifesoham
Posts: 186
Joined: 16 Oct 2011, 14:33

Re: private messages received as ***

Postby itsmylifesoham » 11 May 2012, 10:09

all you have to do is set the word filter mode to blacklist thats all. its not a bug.

Return to “SFS2X Questions”

Who is online

Users browsing this forum: Andy608 and 37 guests