Error during Server boot

Post here your questions about SFS2X. Here we discuss all server-side matters. For client API questions see the dedicated forums.

Moderators: Lapo, Bax

nerogun
Posts: 3
Joined: 24 Jun 2011, 17:18
Location: United States

Error during Server boot

Postby nerogun » 24 Jun 2011, 17:23

I'm on win7 64-bit. Here's what happens when I try to launch either SFS2X 32 or 64.

Code: Select all

14:16:27,955 INFO  [main] v2.SmartFoxServer     - Boot sequence starts...
14:16:27,973 INFO  [main] v2.SmartFoxServer     -
 _____ _____ _____    ___ __ __    _____ _____ _____ _____
|   __|   __|   __|  |_  |  |  |  | __  |     |     |_   _|
|__   |   __|__   |  |  _|-   -|  | __ -|  |  |  |  | | |
|_____|__|  |_____|  |___|__|__|  |_____|_____|_____| |_|

14:16:28,741 INFO  [main] v2.SmartFoxServer     - License code not found, starti
ng Community Edition license
14:16:28,741 INFO  [main] core.SFSEventManager     - AnonymousService-1 initaliz
ed
14:16:28,809 INFO  [main] impl.DefaultFileReplicator     - Using "C:\Users\Jon\A
ppData\Local\Temp\vfs_cache" as temporary files store.
14:16:28,966 INFO  [main] v2.SmartFoxServer     - License loaded

===================================
LICENSE DETAILS
-----------------------------------
Type            : Community Edition
Max users       : 100
===================================

14:16:28,972 INFO  [main] managers.SFSBannedUserStorage     - BanUserStorage ini
tialized
14:16:28,994 INFO  [main] managers.SFSBannedUserManager     - BanUser data loade
d: 0 records.
14:16:29,018 INFO  [main] config.SFSConfigurator     - Loading: zones\GameLobby.
zone.xml
14:16:29,099 INFO  [main] config.SFSConfigurator     - Loading: zones\SimpleChat
.zone.xml
14:16:29,136 INFO  [main] managers.SFSZoneManager     -

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
 >> Zone: GameLobby
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

14:16:29,182 INFO  [main] managers.SFSZoneManager     - Creating room: (default)
 The Lobby
14:16:29,196 INFO  [main] api.SFSApi     - Room created: [ Room: The Lobby, Id:
0, Group: default, isGame: false ]
14:16:29,198 INFO  [main] managers.SFSZoneManager     -

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
 >> Zone: SimpleChat
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

14:16:29,207 INFO  [main] managers.SFSZoneManager     - Creating room: (default)
 The Lobby
14:16:29,210 INFO  [main] api.SFSApi     - Room created: [ Room: The Lobby, Id:
1, Group: default, isGame: false ]
14:16:29,234 INFO  [main] Extensions     - {sfsTris}: SFSTris2X Extension starte
d, rel. 1.0.5
14:16:29,250 INFO  [main] api.SFSApi     - Room created: [ Room: AdminRoom, Id:
2, Group: default, isGame: false ]
14:16:29,262 INFO  [main] core.AdminToolService     - AdminTool Service started
*sys-package-mgr*: processing new jar, 'C:\Program Files\Java\jre6\lib\resources
.jar'
*sys-package-mgr*: processing new jar, 'C:\Program Files\Java\jre6\lib\rt.jar'
*sys-package-mgr*: processing new jar, 'C:\Program Files\Java\jre6\lib\jsse.jar'

*sys-package-mgr*: processing new jar, 'C:\Program Files\Java\jre6\lib\jce.jar'
*sys-package-mgr*: processing new jar, 'C:\Program Files\Java\jre6\lib\charsets.
jar'
*sys-package-mgr*: processing new jar, 'C:\Program Files\Java\jre6\lib\ext\dnsns
.jar'
*sys-package-mgr*: processing new jar, 'C:\Program Files\Java\jre6\lib\ext\dns_s
d.jar'
*sys-package-mgr*: processing new jar, 'C:\Program Files\Java\jre6\lib\ext\local
edata.jar'
*sys-package-mgr*: processing new jar, 'C:\Program Files\Java\jre6\lib\ext\sunjc
e_provider.jar'
14:16:32,152 WARN  [main] mortbay.log     - failed SelectChannelConnector@0.0.0.
0:8080: java.net.BindException: Address already in use: bind
14:16:32,153 WARN  [main] mortbay.log     - failed Server@5aa2bb54: java.net.Bin
dException: Address already in use: bind
14:16:32,156 ERROR [main] v2.SmartFoxServer     -
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
Exception: java.net.BindException
Message: Address already in use: bind
Description: Unexpected error during Server boot. The server cannot start.
Solution: Please email us the content of this error message, including the stack
 trace to support@smartfoxserver.com
+--- --- ---+
Stack Trace:
+--- --- ---+
sun.nio.ch.Net.bind(Native Method)
sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source)
sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source)
org.mortbay.jetty.nio.SelectChannelConnector.open(SelectChannelConnector.java:21
6)
org.mortbay.jetty.nio.SelectChannelConnector.doStart(SelectChannelConnector.java
:315)
org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
org.mortbay.jetty.Server.doStart(Server.java:235)
org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
com.smartfoxserver.v2.http.SFSHttpServer.start(SFSHttpServer.java:92)
com.smartfoxserver.v2.SmartFoxServer.start(SmartFoxServer.java:221)
com.smartfoxserver.v2.Main.main(Main.java:31)
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

jurekf
Posts: 69
Joined: 08 Dec 2010, 23:46

Postby jurekf » 25 Jun 2011, 00:12

You probably have SFS2X running as a service as well as standalone. You should turn it off, or set your current standalone to run off another port.
nerogun
Posts: 3
Joined: 24 Jun 2011, 17:18
Location: United States

Postby nerogun » 25 Jun 2011, 13:33

You probably have SFS2X running as a service as well as standalone. You should turn it off, or set your current standalone to run off another port.


Thank you for your input. I stopped the service and changed the port in server.xml but I still get the same error. Any idea what else it might be?
jurekf
Posts: 69
Joined: 08 Dec 2010, 23:46

Postby jurekf » 25 Jun 2011, 13:49

The error is basically saying the port you specified is in use; perhaps your server is being launched twice somehow.

Try this:

1. Select a random port
2. Test if it's in use by "telnet 127.0.0.1 <portnumber>"
3. If it can connect, it's already in use, go back to 1.
4. Change port number to this
5. Open up task manager, kill all java processes.
6. Start your server
7. If there is an error, check task manager again and see how many java processes are running.
tchen
Posts: 191
Joined: 11 Dec 2010, 14:14

Postby tchen » 27 Jun 2011, 00:57

It is the built in Jetty server that's giving you problems (see the trace at org.mortbay.jetty.nio.SelectChannelConnector) so you likely have another web server running on port 8080.
nerogun
Posts: 3
Joined: 24 Jun 2011, 17:18
Location: United States

Postby nerogun » 29 Jun 2011, 15:56

tchen was right! Thank you that worked for me!

Return to “SFS2X Questions”

Who is online

Users browsing this forum: No registered users and 17 guests