SFS2X - Error sending byte array

Post here your questions about SFS2X. Here we discuss all server-side matters. For client API questions see the dedicated forums.

Moderators: Lapo, Bax

Alex
Posts: 131
Joined: 03 Sep 2006, 09:15

Postby Alex » 30 Apr 2011, 08:06

Hi

I'll try to reproduce the problem - but as I said it is random and is on my live server so its bit difficult. Here is same more info from the client side:


Code: Select all

[SFS - DEBUG] Handling Data: 6861, previous state: 0/-30566
User avatar
Lapo
Site Admin
Posts: 21116
Joined: 21 Mar 2005, 09:50
Location: Italy

Postby Lapo » 30 Apr 2011, 08:18

Doesn't it show up locally?
On the live server it could be due to a network error, more difficult to spot. If it's a SFS problem it should show uo anywhere.
Lapo
--
gotoAndPlay()
...addicted to flash games
Alex
Posts: 131
Joined: 03 Sep 2006, 09:15

Postby Alex » 30 Apr 2011, 08:28

Hi

What I have is a game - and the error occurs when spectator joins and ask for the game. So when i send the complete state of the game - sometimes I get the error - sometimes not. But the problem is that every time the spectator joins the game, its a different state of the game so its little bit hard to reproduce.
User avatar
Lapo
Site Admin
Posts: 21116
Joined: 21 Mar 2005, 09:50
Location: Italy

Postby Lapo » 30 Apr 2011, 08:42

It shouldn't be too difficult, but you should store the binary data on disk on the server side so that you can retrieve it later for testing.
Each file should have an ID, a progressive number can be just fine and you should log a simple message every time you send the data, something like "Now sending binary data with ID: xxx"

Try running one spectator in the Flash IDE with the SFS debugging turned on. As soon as you get the error you can go back on the server, grab the binary data and report to us.

We will need the binary file and the transcript of the client debug session
Lapo

--

gotoAndPlay()

...addicted to flash games
Alex
Posts: 131
Joined: 03 Sep 2006, 09:15

Postby Alex » 30 Apr 2011, 08:50

OK. I'll try to do that
Alex
Posts: 131
Joined: 03 Sep 2006, 09:15

Postby Alex » 30 Apr 2011, 16:38

Hi Lapo

I've send you more info on the email
jcmj
Posts: 1
Joined: 18 May 2011, 20:06

Postby jcmj » 18 May 2011, 20:17

Hi Lapo

I work with leogesteira, that one with the initial problem.
I have found a problem with certain size messages in SFS2X, and managed to create a Kludge to avoid the problem that leogesteira had.
Would you prefer that I send you an email with the explanation, or should I post here.

PS: I believe that you would create a pacth to solve this problem
jurekf
Posts: 69
Joined: 08 Dec 2010, 23:46

Postby jurekf » 18 May 2011, 23:46

I think a problem we had is related to yours.

Once one of our SFSObject ByteArrays passed a certain size (on the order of 180kb IIRC) errors were thrown on the client side.

Another symptom was that the server would "freeze" one of the clients (no messages processed) until another client logged in or sent a message.

We worked around both symptoms by sending bulk data over HTTP instead.

Just wanted to say that as this particular bug is not isolated.
User avatar
Lapo
Site Admin
Posts: 21116
Joined: 21 Mar 2005, 09:50
Location: Italy

Postby Lapo » 23 May 2011, 17:12

The problem is currently fixed.
We're working on the last bits before releasing the new update.

Stay tuned :)

p.s. = anyways if you have a reproducible case we suggest to send it via email, we'll be glad to take a look and make sure it works with the new update.
Lapo

--

gotoAndPlay()

...addicted to flash games

Return to “SFS2X Questions”

Who is online

Users browsing this forum: No registered users and 25 guests