custom login and animation problem

Post here all your questions related with SmartFoxServer .Net/Unity3D API

Moderators: Lapo, Bax

kano
Posts: 71
Joined: 04 Dec 2010, 00:44
Location: Asturias

custom login and animation problem

Postby kano » 12 Dec 2010, 13:02

hi, i have now a new problem.If i use a custom login in my game, send me a error about null refernce(in fire animation), but i f i dont use custom ligin dont send me any error.
im using this script:

Code: Select all

function Start()
{
    charController = GetComponent(CharacterController);
    animation.wrapMode = WrapMode.Loop;
   animation["fire"].wrapMode = WrapMode.Once;
   
   
   animation["idle"].layer = -1;
   animation["walk"].layer = -1;
   animation["run"].layer = -1;
   animation["jump"].layer = -1;

   
   animation.Stop();
   
   
   
}
ThomasLund
Posts: 1297
Joined: 14 Mar 2008, 07:52
Location: Sweden

Postby ThomasLund » 12 Dec 2010, 13:27

This code has no reference to SFS at all. So without proper errors in log + relevant code or even best a repro case, then no one will be able to help you based on this post.

/Thomas
kano
Posts: 71
Joined: 04 Dec 2010, 00:44
Location: Asturias

Postby kano » 12 Dec 2010, 14:44

you are right.This code is not the problem.sorry.I have two errors in two scripts, but send the same error null reference excepcion.But errors, just sending when in config.xml in smartfox i say custom login =true.my custon login works, but in game send those errors.If i say custom login=false dont send any errors.
The nulls reference are one in the animation script, and other in bouble popup.and i dont know why.any idea?


sorry for my bad english
thanks.
ThomasLund
Posts: 1297
Joined: 14 Mar 2008, 07:52
Location: Sweden

Postby ThomasLund » 12 Dec 2010, 15:14

If you set custom login = true in the server config - do you also actually have a custom login extension which works as it has to - setting user ids, sending room lists etc like described in the manual?

/Thomas
kano
Posts: 71
Joined: 04 Dec 2010, 00:44
Location: Asturias

Postby kano » 12 Dec 2010, 15:29

yes, i think.im usin get user id, but i dont send room list in extension, i use get room list in my loggui.i think the extension is ok.my custom login works , i see other players, and how they move(with retarding for now),and i see the animations for others players, for that i think the login is ok.but is the unic diference between send error or not.






i fix it. sorry for questions, it was my fault.some animations was mising.
thanks.

Return to “.Net / Unity3D API”

Who is online

Users browsing this forum: No registered users and 1 guest