Can't connect to SFS on remote server

Post here all your questions related with SmartFoxServer .Net/Unity3D API

Moderators: Lapo, Bax

TheClaus
Posts: 4
Joined: 01 Dec 2009, 20:20
Location: California

Can't connect to SFS on remote server

Postby TheClaus » 15 Apr 2011, 01:53

I was checking out this tutorial and it works fine locally on the lan but as soon as I moved it to a remote server it never connects.

I was trying it out on Amazon EC2 and made sure that I could telnet to 9339 and was able to but when in Unity it wouldn't connect.

I then dropped EC2 in favor of Rackspace Cloud(what a difference) and still unable to connect through Unity to the server. I can however telnet.

If anyone can help me out that would be great.

Thanks

Eric Clausing
appels
Posts: 464
Joined: 28 Jul 2010, 02:12
Contact:

Postby appels » 15 Apr 2011, 08:38

it's probably the security of the webplayer thats preventing you to connect.
you need to read about the sandbox security of the webplayer.
you can easily test it if you try to connect with a standalone build of your unity game.
TheClaus
Posts: 4
Joined: 01 Dec 2009, 20:20
Location: California

Postby TheClaus » 15 Apr 2011, 12:47

I was testing this through the Unity Editor rather than trying it out through web player or standalone build. Does that make a difference?
appels
Posts: 464
Joined: 28 Jul 2010, 02:12
Contact:

Postby appels » 15 Apr 2011, 14:58

yes, even in the editor when your build settings are set to webplayer you must prefetch the policy. change the settings to standalone and you don't need it.

Return to “.Net / Unity3D API”

Who is online

Users browsing this forum: No registered users and 2 guests