Can't for the life of me get the license server to run

Need help with SmartFoxServer? You didn't find an answer in our documentation? Please, post your questions here!

Moderators: Lapo, Bax

flarb
Posts: 131
Joined: 15 Oct 2007, 21:07
Location: Home of the Body Bag
Contact:

Can't for the life of me get the license server to run

Postby flarb » 06 Oct 2009, 23:10

Has anyone successfully set up the license server on a Rackspace CentOS slice communicating with an EC2 instance?

I've tried for 2 days with no dice.

On my Debian Etch EC2 instance, I blew open port 60006 in the Amazon security group. I double checked from inside the instance and that port is available in the security group.

I made a CentOS slice on rackspace--used lokkit to open up 8080 and 60006. The license server runs. I can connect to the web interface for the license server, no problem. When I run smartfox on my EC2 instance, It says:

LS: Connection failed, LS was not found at xxx.xxx.xxx.xxx:60006

When I telnet to this port it says connection refused. Running netstat on the CentOS slice running the license server shows the license server is listening on 60006:

tcp 0 0 ::ffff:127.0.0.1:60006 :::* LISTEN

Looking at the iptables file it shows the port is open. (As edited by lokkit)

I am entirely and completely stumped. Boy do I love this license server!
flarb
Posts: 131
Joined: 15 Oct 2007, 21:07
Location: Home of the Body Bag
Contact:

Postby flarb » 06 Oct 2009, 23:11

BTW running nsmap on my license server's IP it shows:

PORT STATE SERVICE
60006/udp closed unknown


but then again when I run it on 8080 (which works) it shows:

PORT STATE SERVICE
8080/udp filtered unknown


So it leads me to believe there is some CentOS firewall issue deep deep down somewhere lokkit is not addressing.

!!!!
flarb
Posts: 131
Joined: 15 Oct 2007, 21:07
Location: Home of the Body Bag
Contact:

Postby flarb » 07 Oct 2009, 21:28

Oh also, I turned off the firewall entirely and I still can't connect to port 6006. If I telnet to the port from localhost it works--so it is listening. But no matter what I do, whether it's setting up firewall rules or turning off the firewall entirely, I cannot connect to 60006 from the outside.
flarb
Posts: 131
Joined: 15 Oct 2007, 21:07
Location: Home of the Body Bag
Contact:

Postby flarb » 07 Oct 2009, 21:38

Is there a way to change the port the license server listens on? I'm convinced there's some weird filter on Rackspace Cloud blocking certain ports. They claim they don't have one, but there's just no other explanation.
flarb
Posts: 131
Joined: 15 Oct 2007, 21:07
Location: Home of the Body Bag
Contact:

Postby flarb » 07 Oct 2009, 22:45

Ok, I've confirmed rackspace cloud does not block ports. I've narrowed it down to this issue. When I do this:

netstat -anp | grep 60006

I see this:

tcp 0 0 ::ffff:127.0.0.1:60006 :::* LISTEN 3580/java

That tells me that the license server listening only for connections from LOCALHOST.

What is going on? How do I configure the license server to listen to outside connections? I need to turn that 127.0.0.1 to the IP of my VPS Rackspace Cloud instance.

Why is this happening anyway? Where is it pulling 127.0.0.1 from?
flarb
Posts: 131
Joined: 15 Oct 2007, 21:07
Location: Home of the Body Bag
Contact:

Postby flarb » 08 Oct 2009, 20:24

Thanks to SmartFox support, we figured out the problem was I was running the 32-bit server on a 64 bit instance. Now it works great!

Although I think in a future version, the license server should give you an error when you try to run it on the wrong architecture.
flarb
Posts: 131
Joined: 15 Oct 2007, 21:07
Location: Home of the Body Bag
Contact:

Postby flarb » 08 Oct 2009, 20:36

Ok I spoke a bit too soon--it's still only listening on localhost. How do I get the license server to listen to outside connections? Do I need to have at least one paid license in there or something?

Return to “SmartFoxServer 1.x Discussions and Help”

Who is online

Users browsing this forum: No registered users and 21 guests