Help With my first SmartFoxServer Prog

Need help with SmartFoxServer? You didn't find an answer in our documentation? Please, post your questions here!

Moderators: Lapo, Bax

User avatar
mariana
Posts: 77
Joined: 26 Mar 2007, 11:15
Location: Buenos Aires, Argentina

Postby mariana » 06 Aug 2010, 20:03

BigFish:

obviously my problem has to do with where classes are located and how the path is set in my .fla file.

I've tried many combinations that have resulted in anywhere between 3 and 62 errors.

My .fla and .swf files are all in a folder in my Desktop called "Games"

I downloaded the latest version of SFS for Mac. Inside I found a folder called "Flash API".

Can you PLEASE answer me these questions:
1. Where should I place the folder "Flash API"? if it doesn't matter where, I'd prefer to place it inside the folder "Games". Up to now, as I had the folder "it" inside Games, right next to the .fla files, the only path I specified was "."

2. How EXACTLY should I set the path in the ActionScript3 settings, based on the location of the "Flash API" folder?

3. should I copy the entire "Flash API" folder or of its subFolders? if so, which?

Thank you, this problem has me stopped for several days now....

Mariana
:(
User avatar
BigFIsh
Posts: 1698
Joined: 25 Feb 2008, 19:26
Location: New Zealand

Postby BigFIsh » 06 Aug 2010, 20:21

hello, the JSON class is located inside the "com" folder inside that same folder where you got the "it" package from. So you'll need to copy the "com" folder and place it inside the same folder where you project is.
Smartfox's forum is my daily newspaper.
User avatar
mariana
Posts: 77
Joined: 26 Mar 2007, 11:15
Location: Buenos Aires, Argentina

Postby mariana » 07 Aug 2010, 00:11

BigFish:

I had already tried that, but I tried it again.

Now I get 62 errors!

Can somebody PLEASE check if there is not a bug in the MacOS classes?

This is getting to be a bit much, don't you think? :evil:

Mariana
User avatar
BigFIsh
Posts: 1698
Joined: 25 Feb 2008, 19:26
Location: New Zealand

Postby BigFIsh » 07 Aug 2010, 01:08

Mariana, I didn't know there was page two of this topic :shock: as I answered to the question in the previous page (not to the first one on page 2)

Alright, I'm sure there're some confusion somewhere.

1. Yes, the "it" folder inside Games is fine

2. Leave the path in your AS3 library settings to what you said before. A period (.) - at compile time, Flash will search inside the folder where your main flash application is located. So, assuming your main application is inside the "Game" folder - it will search for packages (such as it.gotoandPlay.smartfox and com.adobe.serialization) from that folder. Just to clarify - it.gotoandplay.smartfoxserver is same as /it/gotoAndPlay/smartFox/ in terms of directory (a.k.a folders).

3. So, therefore yes - you copy both subfolders inside that AS3 API folder (the "it" folder, and "com" folder) inside your "Game" folder. So, when flash gets compiled - it should be able to find com.adobe.serialization.json path because the /com/adobe/serialization/json/ directory exists in your "Game" folder.

If you're still getting the same errors, check if /com/adobe/serialization/json is valid (i.e. do those folders exist?).
Smartfox's forum is my daily newspaper.
User avatar
mariana
Posts: 77
Joined: 26 Mar 2007, 11:15
Location: Buenos Aires, Argentina

Postby mariana » 07 Aug 2010, 13:43

BigFish:

I did all you suggested:
placed the it and com folders in the Games folder
set the classpath to .
checked that the com path was valid.

I also corrected all possible errors not related to the SFS classes.

I was left with 36 errors.

I made a folder with screenShots of:
the JSON path
the Room path
the AS3 settings panel
the import statements in Frame 1 of my fla file
the 36 compiler errors

How can I send it to you as an attachment?

Mariana
:(
User avatar
BigFIsh
Posts: 1698
Joined: 25 Feb 2008, 19:26
Location: New Zealand

Postby BigFIsh » 07 Aug 2010, 20:26

You'll need to zip them up and put it somewhere on your server then provide a link in your next reply pointing me to it.
Smartfox's forum is my daily newspaper.

Return to “SmartFoxServer 1.x Discussions and Help”

Who is online

Users browsing this forum: No registered users and 33 guests