Login/Register system

Need help with SmartFoxServer? You didn't find an answer in our documentation? Please, post your questions here!

Moderators: Lapo, Bax

User avatar
rjgtav
Posts: 2813
Joined: 19 Apr 2009, 11:31
Location: Lisbon, Portugal

Login/Register system

Postby rjgtav » 21 Apr 2009, 17:19

Hi there, I'm making a mmorpg that needs a login and a register system. I already tried the customlogin example and i used the sfslogin.php but it didn't work. It always gave me the error message "Wrong user or pass". Please can anyone help me developing a login system and a register system* for my game?


*I prefer the systems in PHP (without mysql) and with flash.
User avatar
BigFIsh
Posts: 1698
Joined: 25 Feb 2008, 19:26
Location: New Zealand

Postby BigFIsh » 23 Apr 2009, 04:28

If you're getting "wrong user or pass" all the time, that means that .php login is working correctly - but the login information is wrong. Perhaps, it's the outgoing or incoming parameters that you need to double check (debug it).
Smartfox's forum is my daily newspaper.
User avatar
rjgtav
Posts: 2813
Joined: 19 Apr 2009, 11:31
Location: Lisbon, Portugal

Postby rjgtav » 23 Apr 2009, 17:51

Ty for the help. Noob question: How do i debug? And how can i do a register file to this file based database? thank you
User avatar
BigFIsh
Posts: 1698
Joined: 25 Feb 2008, 19:26
Location: New Zealand

Postby BigFIsh » 25 Apr 2009, 01:32

Usually, you'll find the solution in the manual :)

But, to debug:

add these parameters in your config.xml file

<DebugIncomingMessages>true</DebugIncomingMessages>
<DebugOutGoingMessages>true</DebugOutGoingMessages>

It's recommended to turn these off during production of course :)

Could you rephrase "And how can i do a register file to this file based database?" I don't quite follow
Smartfox's forum is my daily newspaper.
User avatar
rjgtav
Posts: 2813
Joined: 19 Apr 2009, 11:31
Location: Lisbon, Portugal

Postby rjgtav » 26 Apr 2009, 13:59

Ty for the help. I already added the :<DebugIncomingMessages>true</DebugIncomingMessages>
<DebugOutGoingMessages>true</DebugOutGoingMessages> to my server's config.xml but i don't see any debug in the start.bat or the debug is in other file? I want to create a register.php file to the people register and store the data to the login.php. Please help me. thank you
User avatar
Lapo
Site Admin
Posts: 21012
Joined: 21 Mar 2005, 09:50
Location: Italy

Postby Lapo » 27 Apr 2009, 09:29

It depends on which SFS version you are using... those require SFS PRO 1.6.3 or higher.
Lapo
--
gotoAndPlay()
...addicted to flash games
User avatar
rjgtav
Posts: 2813
Joined: 19 Apr 2009, 11:31
Location: Lisbon, Portugal

Postby rjgtav » 28 Apr 2009, 18:06

Ty Lapo. I have the SFS basic but i don't know why it don't works. I already tried a lot of tutorials about php login/register systems with flash and mysql or only with php and flash but nothing works. I need some help making the system to my game. Thank you.
User avatar
rjgtav
Posts: 2813
Joined: 19 Apr 2009, 11:31
Location: Lisbon, Portugal

Postby rjgtav » 04 May 2009, 17:36

Hi there again. After trying to do lots of tutorials, i found that the problem isn't that the flash don't receives the answer. The problem is that flash don't send's the login data to the php, so the php can't send an answer to flash. Please anybody help me solving this problem. thank you

Return to “SmartFoxServer 1.x Discussions and Help”

Who is online

Users browsing this forum: No registered users and 3 guests