<AutoSendPolicyFile>

Need help with SmartFoxServer? You didn't find an answer in our documentation? Please, post your questions here!

Moderators: Lapo, Bax

piru
Posts: 9
Joined: 17 Apr 2005, 04:39

<AutoSendPolicyFile>

Postby piru » 17 Apr 2005, 04:41

When does smartfoxserver generates the policy file?
User avatar
Lapo
Site Admin
Posts: 21128
Joined: 21 Mar 2005, 09:50
Location: Italy

Postby Lapo » 17 Apr 2005, 13:20

It is generated immediately, as soon as the client connects to the server. For more info on how having Flash read the policy file from socket refer to the SmartFoxServer documentation >> Section 3.1

Let me know if you have any more questions
Lapo
--
gotoAndPlay()
...addicted to flash games
piru
Posts: 9
Joined: 17 Apr 2005, 04:39

The same

Postby piru » 19 Apr 2005, 03:55

This is the situation,
For example I upload the simpleChat,swf into my page server, and on my PC y RUN SMART FOX SERVER.

I tried to use the code "System.security.loadPolicyFile("xmlsocket://192.168.0.1:9339")", but ActionScript tells that there is no method with the name 'loadPolicyFile'. (I'M USSING ACTIONSCRIPT 2 AND FLASH 7).

What shoulf¿d I do. And if I create the crossdomain.xml where should I put it?
User avatar
Lapo
Site Admin
Posts: 21128
Joined: 21 Mar 2005, 09:50
Location: Italy

Postby Lapo » 19 Apr 2005, 08:41

If you're using AS2 and Flash MX 2004 it must work. Are you sure the synthax is right? Remember that AS2 is case sensitive!

Please, verify your synthax and check if uppercase and lowercase character match.

You can also check the documentation from Macromedia here >> http://livedocs.macromedia.com/flash/mx ... 01752.html

:)
Lapo

--

gotoAndPlay()

...addicted to flash games
piru
Posts: 9
Joined: 17 Apr 2005, 04:39

Postby piru » 19 Apr 2005, 21:45

I Typed the "System.security.loadPolicyFile"xmlsocket://192.168.0.1:9339")",
User avatar
Lapo
Site Admin
Posts: 21128
Joined: 21 Mar 2005, 09:50
Location: Italy

Postby Lapo » 22 Apr 2005, 11:03

did you find any errors in what you were typing? Is it working now?

That command is recognized by the flash player 7.0.19 or later, maybe you should check if you have the latest version.
Lapo

--

gotoAndPlay()

...addicted to flash games
piru
Posts: 9
Joined: 17 Apr 2005, 04:39

Postby piru » 27 Apr 2005, 06:03

I downloaded flash mx updater (to version 7.2), I downloaded flash player 7.0.19 and the updater. Still, it says

There is no method with the name 'loadPolicyFile'.
System.security.loadPolicyFile("xmlsocket://192.168.0.1:9339");

In the swf propetires i'm using AS2 and FLASH player 7 (no 7.0.19, this version dosen't shows up). What should I do?
User avatar
Lapo
Site Admin
Posts: 21128
Joined: 21 Mar 2005, 09:50
Location: Italy

Postby Lapo » 27 Apr 2005, 06:24

I am sorry but I can't say.
If I copy the same exact line you reported here in a new Flash MX 2004 document and launch it (CTRL + ENTER) I don't get any errors, just like it is supposed to be.

Did you try that? That single command in a new flash doc?

Maybe you have a problem with your Flash installation? A conflict with flash players? Maybe you have more f. players installed?

I am sorry but at the moment I have no other ideas about your specific problem.

If anybody else has ever had a similar error please report it here.
Lapo

--

gotoAndPlay()

...addicted to flash games
User avatar
Lapo
Site Admin
Posts: 21128
Joined: 21 Mar 2005, 09:50
Location: Italy

Postby Lapo » 27 Apr 2005, 06:29

I've done a few extra researches and found this:
http://livedocs.macromedia.com/flash/mx ... 01098.html

It seems you're not the only one getting this problem.

As stated in the end of that page try this instead:

System.security["loadPolicyFile"]("xmlsocket://192.168.0.1:9339")

Let me know if that works
Lapo

--

gotoAndPlay()

...addicted to flash games
piru
Posts: 9
Joined: 17 Apr 2005, 04:39

Postby piru » 27 Apr 2005, 16:04

there is no error with [], you are a genius.I'll try if it worls thanks. A few questions: the ip of the policy file should be my ip or the ip where the swf is uploaded?, if it is my PC IP, i should put the IP my router gives me or the ip the browser sees?
piru
Posts: 9
Joined: 17 Apr 2005, 04:39

Postby piru » 27 Apr 2005, 16:24

Where should I put the policy file????
User avatar
Lapo
Site Admin
Posts: 21128
Joined: 21 Mar 2005, 09:50
Location: Italy

Postby Lapo » 27 Apr 2005, 19:50

piru wrote:there is no error with [], you are a genius.I'll try if it worls thanks. A few questions: the ip of the policy file should be my ip or the ip where the swf is uploaded?, if it is my PC IP, i should put the IP my router gives me or the ip the browser sees?


you must put the IP address of the server
Where should I put the policy file????


Nowhere! :) If you use this method the policy file is automatically created by the server and Flash will get it from there! :)
Lapo

--

gotoAndPlay()

...addicted to flash games
piru
Posts: 9
Joined: 17 Apr 2005, 04:39

Postby piru » 27 Apr 2005, 21:57

The server is instaled and running on my PC, so I should put the IP created or asigned by the router or the one that the browser can see
User avatar
Lapo
Site Admin
Posts: 21128
Joined: 21 Mar 2005, 09:50
Location: Italy

Postby Lapo » 28 Apr 2005, 06:40

Just use the same ip address you have used in the config.xml
Lapo

--

gotoAndPlay()

...addicted to flash games
piru
Posts: 9
Joined: 17 Apr 2005, 04:39

Postby piru » 15 Jun 2005, 18:19

Lapo wrote:Just use the same ip address you have used in the config.xml


In the config.xml file I put the IP assignes by the router in this case 192.168.3.1++, and it runs perfectly without a problem. The applications and movies can connect with the server when they are in mi PC, but outside don't.
I tried putting the ROUTERS IP in the MC outside my computer and the IP assigned by the router in the config file but nothing happends, do you have any idea of waht should i do?.. The MC is in my web server and SFS is in mi pc. Also in the browser it says CONNECTING WITH <routers ip>, then WAITING FOR <routers ip> Take a lookhttp://www.amsgames.com/Chat.swf

Return to “SmartFoxServer 1.x Discussions and Help”

Who is online

Users browsing this forum: No registered users and 16 guests