Help Connection.

Need help with SmartFoxServer? You didn't find an answer in our documentation? Please, post your questions here!

Moderators: Lapo, Bax

xxxxxxss
Posts: 9
Joined: 27 Feb 2008, 04:34

Help Connection.

Postby xxxxxxss » 29 Feb 2008, 02:53

Heres what I done I:

Made the config.xml ip the same as my ip in ipconfig/all.

Made the ip in the swf to my routers ip address at www.whatismyip.com

I made the crossdomain.xml file "*" so it works any were.

I added system.security... (my ip from www.whatismyip.com:port 9339).

I turned my fire wall of so it didnt block ports.

I portforwarded my router so starting port is 9339 ending port is 9339 and those other 2 are 9339 with name of smartfox server and added it.

What am i doing rong?
User avatar
Lapo
Site Admin
Posts: 21139
Joined: 21 Mar 2005, 09:50
Location: Italy

Postby Lapo » 29 Feb 2008, 06:31

Let me know your IP address, we'll check remotely
Lapo
--
gotoAndPlay()
...addicted to flash games
grimmy
Posts: 7
Joined: 28 Feb 2008, 12:35

Postby grimmy » 29 Feb 2008, 08:20

Yeah, thats exactly the same as me. Fingers crossed you figure it out and let us all know.
BTW in my windows routing configuration from ipconfig/all it says IP routing Enable....No. That doesnt sound right does it?
cheers and good luck.
User avatar
BigFIsh
Posts: 1698
Joined: 25 Feb 2008, 19:26
Location: New Zealand

Postby BigFIsh » 04 Mar 2008, 07:27

Have you tried testing the flash with various browsers and inside/outside the network?

Sometimes error occurs when trying to connect to the flash with external ip address from the same computer that is running the fox server.

Solution to this problem is to change the .swf ip address to local address (i.e. 127.0.0.1) when testing flash movies.

Return to “SmartFoxServer 1.x Discussions and Help”

Who is online

Users browsing this forum: No registered users and 17 guests