MySQL Database connector not working!!

Need help with SmartFoxServer? You didn't find an answer in our documentation? Please, post your questions here!

Moderators: Lapo, Bax

the.rahul
Posts: 3
Joined: 08 Oct 2011, 11:04

MySQL Database connector not working!!

Postby the.rahul » 08 Oct 2011, 11:23

Hi,

I have a remote Server which runs on RHEL 5.5 and has MySQL 5.1, Smartfox PRO 1.6. When the <DatabaseManager active="true"> parameter is FALSE, the SFS Service runs successfully on the Server. However, as soon as the value is TRUE, the service stops.

The config.xml looks something like this:

<DatabaseManager active="true">

<Driver>org.gjt.mm.mysql.Driver</Driver>

<ConnectionString>jdbc:mysql://myremoteIP:3306/dbname</ConnectionString>

<UserName>username</UserName>

<Password>mypassword</Password>

<TestSQL><![CDATA[SELECT COUNT(*) FROM TABLENAME]]></TestSQL>

<MaxActive>10</MaxActive>

<MaxIdle>10</MaxIdle>

<OnExhaustedPool>fail</OnExhaustedPool>

<BlockTime>5000</BlockTime>

</DatabaseManager>


I've tried most of the steps discussed in this forum regarding this, namely:

- Downloaded another version of MySQL connector from the MYSQL website
- Added the location to the start.sh file
- Added the necessary line in wrapper.conf
- Tried "export set CLASSPATH=/usr/smartfox/SFS_PRO_1.6.0/jre/lib/ext/mysql- connector-java-5.1.5-bin.jar:$CLASSPATH "
- the MySQL driver is inside the SFSPRO destination/jre/lib/ext folder

Are there any other steps that I need to follow? I am new to Smartfox.

Thanks in advance...
User avatar
BigFIsh
Posts: 1698
Joined: 25 Feb 2008, 19:26
Location: New Zealand

Postby BigFIsh » 11 Oct 2011, 04:56

Could you please provide us the error dump provided in the log after unabling to start smartfoxserver? They will be located in {path to SFS}\Server\logs\
Smartfox's forum is my daily newspaper.

Return to “SmartFoxServer 1.x Discussions and Help”

Who is online

Users browsing this forum: No registered users and 15 guests