createNPC socket issue

Need help with SmartFoxServer? You didn't find an answer in our documentation? Please, post your questions here!

Moderators: Lapo, Bax

dannyrg
Posts: 19
Joined: 19 Oct 2010, 19:08

createNPC socket issue

Postby dannyrg » 31 Mar 2011, 13:03

Hi,

I've encountered the problem of sockets not closing properly when removing an NPC from the system.
Is there any known workaround to this issue for 1.6.9, other than keeping the NPC's in an ongoing pool for the lifecycle of the server instance?
(this is very cumbersome code to write, just for the purpose of avoiding an annoying bug)

On the same note, does this bug exist in 2X?

Thanks,

Dan
User avatar
BigFIsh
Posts: 1698
Joined: 25 Feb 2008, 19:26
Location: New Zealand

Postby BigFIsh » 01 Apr 2011, 01:31

Can this be reproducible? How many NPC are connected to your server?

There is a similar posting about this (viewtopic.php?t=4560) where there was many NPC connections.
Last edited by BigFIsh on 06 Jul 2011, 23:08, edited 1 time in total.
Smartfox's forum is my daily newspaper.
User avatar
Lapo
Site Admin
Posts: 21791
Joined: 21 Mar 2005, 09:50
Location: Italy

Postby Lapo » 07 Jul 2011, 06:24

Yes it is a known issue. Unfortunately we don't have a workaround at the moment. There's no use in decompiling our code as some user as suggested here. This will infringe our license and the author of that post has already been warned by email.
Besides that you should avoid to create/destroy thousands of NPCs and maybe reuse them instead
Lapo
--
gotoAndPlay()
...addicted to flash games

Return to “SmartFoxServer 1.x Discussions and Help”

Who is online

Users browsing this forum: No registered users and 38 guests