Start.bat is not working

Need help with SmartFoxServer? You didn't find an answer in our documentation? Please, post your questions here!

Moderators: Lapo, Bax

l00t
Posts: 3
Joined: 29 May 2020, 21:44

Start.bat is not working

Postby l00t » 29 May 2020, 21:52

Anytime I open the bat file this is what comes up when it tries to start.


java.io.IOException: Couldn't get lock for /C:/Program Files (x86)/SmartFoxServe
rPRO_1.6.6/Server/logs/smartfox_log_%g.txt
at java.util.logging.FileHandler.openFiles(FileHandler.java:372)
at java.util.logging.FileHandler.<init>(FileHandler.java:306)
at it.gotoandplay.smartfoxserver.SmartFoxServer.initLogger(SmartFoxServe
r.java:496)
at it.gotoandplay.smartfoxserver.SmartFoxServer.run(SmartFoxServer.java:
576)
FATAL ERROR: Could not create log files.


Shutting down server...

java.io.FileNotFoundException: bannedUsers.sfs (Access is denied)
at java.io.FileOutputStream.open(Native Method)
at java.io.FileOutputStream.<init>(FileOutputStream.java:179)
at java.io.FileOutputStream.<init>(FileOutputStream.java:70)
at it.gotoandplay.smartfoxserver.lib.ShutdownManager.run(ShutdownManager
.java:52)
Press any key to continue . . .
User avatar
Lapo
Site Admin
Posts: 21521
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: Start.bat is not working

Postby Lapo » 30 May 2020, 14:03

Hi,
this is because under Windows you don't have write permissions in the "Program Files" folder.
You need to install the server under your own User folder so that write permissions are granted.

Hope it helps
Lapo
--
gotoAndPlay()
...addicted to flash games
l00t
Posts: 3
Joined: 29 May 2020, 21:44

Re: Start.bat is not working

Postby l00t » 06 Jun 2020, 18:27

Lapo wrote:Hi,
this is because under Windows you don't have write permissions in the "Program Files" folder.
You need to install the server under your own User folder so that write permissions are granted.

Hope it helps

Are you talking about the server folder? Because it's in the sfs program files.
User avatar
Lapo
Site Admin
Posts: 21521
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: Start.bat is not working

Postby Lapo » 07 Jun 2020, 09:46

You have installed SFS2X under "C:\Program Files (x86)\..." which doesn't provide file write permissions.
Please uninstall SFS2X and re-install it back in a folder under your User directory, which typically is C:\Users\<YourUserNam>\

Thanks
Lapo

--

gotoAndPlay()

...addicted to flash games
l00t
Posts: 3
Joined: 29 May 2020, 21:44

Re: Start.bat is not working

Postby l00t » 12 Jun 2020, 00:15

But I use SfS Pro
User avatar
Lapo
Site Admin
Posts: 21521
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: Start.bat is not working

Postby Lapo » 12 Jun 2020, 07:24

It's the same thing. The permission issue is due to your operating system (Windows) not what version of SFS you're using :)
Lapo

--

gotoAndPlay()

...addicted to flash games

Return to “SmartFoxServer 1.x Discussions and Help”

Who is online

Users browsing this forum: No registered users and 8 guests