Search found 36 matches

by Zelek
10 Jul 2010, 00:50
Forum: .Net / Unity3D API
Topic: Closing a SFS/Unity Project = Unresponsive App
Replies: 7
Views: 3744

sonicviz wrote:I have the same behaviour


Thank you for the confirmation! Was the problem in your own project, or my test link?
by Zelek
01 Jul 2010, 03:28
Forum: .Net / Unity3D API
Topic: Closing a SFS/Unity Project = Unresponsive App
Replies: 7
Views: 3744

This problem occurs for me in both Firefox and IE, as well as a stand-alone executable. It even occurs when I run 01_SimpleConnect. I only have one computer to test on, but I had a friend test on his computer. He was able to confirm the problem in both Firefox and IE, though it wasn't a problem in C...
by Zelek
29 Jun 2010, 16:35
Forum: .Net / Unity3D API
Topic: Transferring a record set from database to Unity3D (C#)
Replies: 4
Views: 4757

It looks like we have the same setup in the extension. Are you making sure the index passed to GetObj(...) is a string? Notice I'm concatting an empty string. This is my extension code: case "getchat": var sql = "SELECT chaID, usrID, usrName, chaText FROM Chat ..." var queryRes =...
by Zelek
29 Jun 2010, 16:05
Forum: .Net / Unity3D API
Topic: Closing a SFS/Unity Project = Unresponsive App
Replies: 7
Views: 3744

Closing a SFS/Unity Project = Unresponsive App

When I use SFS in a Unity project, closing the application results in a period of about 10 seconds where the application is entirely unresponsive before it closes. This happens in the SFS Tris example project as well as my personal project. It's especially painful in a browser project - it tends to ...
by Zelek
29 Jun 2010, 15:57
Forum: .Net / Unity3D API
Topic: Transferring a record set from database to Unity3D (C#)
Replies: 4
Views: 4757

I'm still learning as well, but here's how my code is set up to get an array of data sent from an extension: public void OnExtensionResponse(object data, string type) { if (type == SmartFoxClient.XTMSG_TYPE_XML) { SFSObject dataObject = (SFSObject)data; SFSObject my...
by Zelek
24 Jun 2010, 22:45
Forum: .Net / Unity3D API
Topic: Repeated connections, delay
Replies: 1
Views: 1706

Repeated connections, delay

My Unity app is currently setup so that it establishes a connection upon start-up. This works great the first time through, but on subsequent start-ups, there is about a 5-20 second delay where Unity is unresponsive while the SmartFox connection request is being processed. What could be causing this...

Go to advanced search