Search found 2805 matches

by rjgtav
14 Nov 2013, 01:51
Forum: SFS2X HTML5 / JavaScript API
Topic: High latency when playing a game
Replies: 36
Views: 16811

Re: High latency when playing a game

Hi,

One thing that directly came to my mind, can you check if the browser is firing multiple times the keypress event when a key is down, instead of firing it ony once each time you press it?
I'd also suggest you to check the system queues and the server's load.

Cheers
by rjgtav
14 Nov 2013, 01:45
Forum: SmartFoxServer 1.x Discussions and Help
Topic: Uppercase
Replies: 5
Views: 2596

Re: Uppercase

Hi, The problem with creating the names on the client-side is that it could generate a name that is already logged in the Zone. I'd really suggest you to follow Lapo's recomendation, as on the server-side you can check whether or not a name already exists much easier than with your own implementatio...
by rjgtav
14 Nov 2013, 01:42
Forum: Server Side Extension Development
Topic: [solved] Using same Java extension in multiple zones
Replies: 4
Views: 3194

Re: [solved] Using same Java extension in multiple zones

Great!
Sorry but I wasn't able to check the forums yesterday, glad you found it ;)
by rjgtav
11 Nov 2013, 01:17
Forum: Server Side Extension Development
Topic: [solved] Using same Java extension in multiple zones
Replies: 4
Views: 3194

Re: Using same Java extension in multiple zones... problems!

Hello, As I don't have much time, I've only tested by creating 2 very simple zones with a same simple Java extension and it created two different instances. Here is the config I've used: <Zone name="javaExtTest1" customLogin="false" buddyList="20"> <Rooms> <Room name=&q...
by rjgtav
11 Nov 2013, 00:39
Forum: Server Side Extension Development
Topic: running smartfoxserver in debugmode
Replies: 3
Views: 3229

Re: running smartfoxserver in debugmode

Good evening, Could you provide some more details about your setup? Are you using SFS2X or SFS Pro? And what do you mean by debug mode? Is it the debug mode on the client side or do you mean the DEBUG level log messages on the console? The first case depends on what client technology you're using. O...
by rjgtav
20 Sep 2013, 23:56
Forum: SFS2X iPhone / iPad / OSX API
Topic: API version 1.1.8 Available
Replies: 32
Views: 13530

Re: API version 1.1.8 Available

@clam61 Where's the SFS2X you're trying to connect to? Is it running on a machine with a reasonable internet connection speed? Have you tried running your app on another phone from a different network provider? Have you tried remote debugging to see if there is any exception firing on the mobile dev...
by rjgtav
20 Sep 2013, 23:43
Forum: SFS2X iPhone / iPad / OSX API
Topic: War game for iOS problem.
Replies: 2
Views: 2305

Re: War game for iOS problem.

Hi,

I suggest you to start by reading the official documentation, at http://docs2x.smartfoxserver.com/, in order to better understand how SmartFoxServer works and how to interact with other clients.

Cheers
by rjgtav
20 Sep 2013, 23:24
Forum: SmartFoxServer 1.x Discussions and Help
Topic: User gets kicked but no message from admin tool
Replies: 3
Views: 2782

Re: User gets kicked but no message from admin tool

I'm sorry but I got a bit confused with your topic.
Are you actually kicking the users via a Moderator/AdminTool, or are you only enabling the badwords and flood filters?
If you're only using the filters, can you post the configuration you're using for them?

Thanks
by rjgtav
20 Sep 2013, 23:21
Forum: SmartFoxServer 1.x Discussions and Help
Topic: SFS 1.x license server on Amazon EC2
Replies: 4
Views: 3205

Re: SFS 1.x license server on Amazon EC2

Hi Peter,

Yes, it is possible to install SmartFoxServer Pro on an Amazon EC2 instance.
Some users have already tried it, and the best way to find their experience is by making a search on the forums:
search.php?keywords=amazon+ec2&fid%5B0%5D=1

Cheers
by rjgtav
20 Sep 2013, 23:18
Forum: SmartFoxServer 1.x Discussions and Help
Topic: Probably a dumb question for those of you who know
Replies: 3
Views: 2471

Re: Probably a dumb question for those of you who know

Hi, It works, but I am quite confused. Does that mean I can test; run it from my website? I thought the website was the place where the php was to be handled. Well, your website is actually a WebServer, like Apache which comes with XAMPP, so yeah, you can host your php files on either your Apache se...
by rjgtav
17 Sep 2013, 23:52
Forum: SmartFoxServer 1.x Discussions and Help
Topic: Probably a dumb question for those of you who know
Replies: 3
Views: 2471

Re: Probably a dumb question for those of you who know

Hi there, SmartFoxServer Pro already comes with a webserver, called Jetty, which you could use for storing your PHP files. The only issue is that the Jetty that comes with SFS is a very light version of it, and so you'll have to install first PHP in there. XAMPP, on the other hand, already comes wit...
by rjgtav
16 Sep 2013, 23:42
Forum: SmartFoxServer 1.x Discussions and Help
Topic: Where i put the .sfl file in Linux Server ?
Replies: 3
Views: 2146

Re: Where i put the .sfl file in Linux Server ?

No problem ;)

Well I'd say that on Linux the license file goes on the same location.
Doesn't it work if you put it under Server/?
by rjgtav
16 Sep 2013, 23:41
Forum: Server Side Extension Development
Topic: java.lang.NullPointerException - NEED HELP!
Replies: 1
Views: 2598

Re: java.lang.NullPointerException - NEED HELP!

Hi, The error you're getting means that you're trying to work with something that is null. By taking a quick look at your code, I'd say that your error is probably on this line: userGender = gender A good way to find out what exactly is happening at your code and why it is happening, is by tracing. ...
by rjgtav
15 Sep 2013, 22:29
Forum: SmartFoxServer 1.x Discussions and Help
Topic: Where i put the .sfl file in Linux Server ?
Replies: 3
Views: 2146

Re: Where i put the .sfl file in Linux Server ?

Hi there,

Just to confirm, is this SmartFoxServer Pro or Basic?
I'm asking this because only those versions use a .sfl file, but you posted it on the SFS2X forums, which is a different product ;)
by rjgtav
15 Sep 2013, 22:24
Forum: SmartFoxServer 1.x Discussions and Help
Topic: Unable to connect: I/O Error
Replies: 7
Views: 2910

Re: Unable to connect: I/O Error

Oh, I thought it was a client-side error.. in that case that error is being thrown by SFS.
You can find the logs at the logs/ folder. You can also check it through the AdminTool.

Cheers

Go to advanced search