Search found 92 matches

by mixart
26 Jan 2010, 19:31
Forum: SmartFoxServer 1.x Discussions and Help
Topic: {NEW} AS3 Flash/Flex Examples
Replies: 18
Views: 34886

Awesome!

Please also correct these AS3 errors in the docs...
viewtopic.php?t=6483
by mixart
01 Sep 2009, 23:27
Forum: SmartFoxServer 1.x Discussions and Help
Topic: Refuse Multiple Connections from same IP Address
Replies: 4
Views: 3871

There is a setting in the config XML file for how many connections are allowed per IP address.

IP Address Filter
<IpFilter>10</IpFilter>
by mixart
31 Aug 2009, 22:25
Forum: SmartFoxServer 1.x Discussions and Help
Topic: How to check is server is running via PHP
Replies: 1
Views: 1555

How to check is server is running via PHP

Is there a way I can show the "status" of the smartfox server via a PHP script so my users can automatically know when the server is up or down?

Perhaps a cron I can run every 5 minutes or so that pings the server to check it is running - any ideas how I would handle this?
by mixart
09 May 2009, 14:24
Forum: SmartFoxServer 1.x Discussions and Help
Topic: { NEW } SmartFoxServer 1.6.6 available!
Replies: 21
Views: 35134

Since the release contains new API (please do check the release notes) you will need to recompile the client application. Thanks Lapo - just wanted to make sure. The release notes tell you how to point to the new API, but do not specifically say it is required and that old SWFs will not work... jus...
by mixart
09 May 2009, 07:03
Forum: SmartFoxServer 1.x Discussions and Help
Topic: { NEW } SmartFoxServer 1.6.6 available!
Replies: 21
Views: 35134

Does this update require a republish of SWFs with the new API or is that only to take advantage of the new features.

i.e. if I update the server will existing SWFs work fine?
by mixart
07 Feb 2009, 09:41
Forum: SmartFoxServer 1.x Discussions and Help
Topic: { Update } SmartFoxServer PRO 1.6.5 is out!
Replies: 30
Views: 25379

I would like to suggest that for future updates there is a better folder structure or something to resolve the following... Since patching updates since 1.6.2 my installation directory is: /SFS_PRO_1.6.2/ I've updated patches to 1.6.5, but the installation folder still reads 1.6.2 - it's just adding...
by mixart
15 Oct 2008, 16:04
Forum: SmartFoxServer 1.x Discussions and Help
Topic: Server occasionally restarts on it's own (log included)
Replies: 7
Views: 3996

Thanks for your help Lapo - will give it a try. P.s. The only way I can determine if the different launcher resolves the problem is to keep the server up and running with the different launcher for a few days. I can't run the script and keep my telnet session open for several days by just running th...
by mixart
15 Oct 2008, 08:41
Forum: SmartFoxServer 1.x Discussions and Help
Topic: Server occasionally restarts on it's own (log included)
Replies: 7
Views: 3996

One last question Lapo... :) I can run start.sh just fine when in the /path/to/SFS/Server folder, but am having troubles getting it to run at startup. I've tried creating a symbolic link ln -s /path/to/SFS/Server/start.sh S99sfs and putting it in my correct rc.d folder and that did not work. I also ...
by mixart
15 Oct 2008, 01:56
Forum: SmartFoxServer 1.x Discussions and Help
Topic: Server occasionally restarts on it's own (log included)
Replies: 7
Views: 3996

I am actually using the ./sfs start option to startup my server. In my rc.d file I have: /home/me/SFS_PRO_1.6.2/Server/sfs start My OS is: CENTOS Enterprise 5.2 i686 P.s. I noticed in my logs I have this line every few minutes, sometimes 5 or more times a minute. Please let me know if this is abnorm...
by mixart
14 Oct 2008, 07:05
Forum: SmartFoxServer 1.x Discussions and Help
Topic: Blocking more then 20 connections after license update.
Replies: 3
Views: 2671

I noticed recent that when I apply my license, if I restart SFS via the adminTool it does not apply the new license, but if I restart SFS at the server level it updates the license. I'm pretty sure this is what happened to me but I haven't re-tested to confirm this was what fixed when I had this pro...
by mixart
14 Oct 2008, 06:13
Forum: SmartFoxServer 1.x Discussions and Help
Topic: Server occasionally restarts on it's own (log included)
Replies: 7
Views: 3996

Server occasionally restarts on it's own (log included)

My users report that occasionally (once every few days) the server kick them out and restart... I've looked through wrapper logs and this is what I can see at the time the restart happens... INFO | jvm 1 | 2008/10/13 21:23:47 | 21:23:47.901 - [ FINE ] > User eggy updates variables: <vars><var n='spe...
by mixart
11 Oct 2008, 09:40
Forum: SmartFoxServer 1.x Discussions and Help
Topic: 1.6.3 update - force login with AS
Replies: 2
Views: 1934

Thanks for the quick reply Lapo - your response makes sense.

Also, thanks for the 1.6.3 update. One reason I'm so happy I use SFS is it is always evolving and being updated :)
by mixart
11 Oct 2008, 08:23
Forum: SmartFoxServer 1.x Discussions and Help
Topic: 1.6.3 update - force login with AS
Replies: 2
Views: 1934

1.6.3 update - force login with AS

I noticed in the 1.6.3 update there is a forcelogin param. However I current use AS to login (not the server side function): smartfox.login(zone, userName, null); Does my method of logging in support this new forcelogin function? There is nothing in the docs regarding this. I'd prefer not to...
by mixart
19 Aug 2008, 05:52
Forum: SmartFoxServer 1.x Discussions and Help
Topic: Connection problems since moving servers
Replies: 6
Views: 3715

I still haven't found a solution to this problem. Anyone got ideas of where I can poke around for troubleshooting. It makes no sense why it works for users, but occasionally will not connect for them (at times when it does not work for some there are users who can connect fine). P.s. Some users don'...
by mixart
09 Aug 2008, 17:33
Forum: SmartFoxServer 1.x Discussions and Help
Topic: Connection problems since moving servers
Replies: 6
Views: 3715

Hosting provider was changed. New server, new datacenter. I managed to get bluebox working (at least for me). Users still being able to connect sometimes and not connecting other times and it doesn't seem to be connecting to bluebox when they cannot connect. My server network/datacenter is very reli...

Go to advanced search