Search found 10 matches

by antuan
09 Jul 2012, 10:15
Forum: SFS2X Java / Android API
Topic: How to use a RoomExtension
Replies: 5
Views: 2556

Re: How to use a RoomExtension

rjgtav, I tried doing what you told me and everything worked fine! My RoomExtension is like following. public class RoomExtension extends BaseSFSExtension{ SmartFoxServer sfs; ScheduledFuture<?> taskHandle; @Override public void init() { sfs = SmartFoxServer.getInstance(); } @Override public void ha...
by antuan
07 Jul 2012, 18:14
Forum: SFS2X Java / Android API
Topic: How to use a RoomExtension
Replies: 5
Views: 2556

Re: How to use a RoomExtension

Hi. Please make sure that when you are sending an ExtensionRequest from the client, you specify to which room to send the request, otherwise it will be sent to the Zone-Level extension. My second problem is about sfs roomExtensions performance. I create 70 rooms, when server started. Each room has ...
by antuan
06 Jul 2012, 15:34
Forum: SFS2X Java / Android API
Topic: How to use a RoomExtension
Replies: 5
Views: 2556

How to use a RoomExtension

Hello, I create a lot of rooms when sfs2x started and also create RoomExtension for each room. Everything works fine. I can see on the admin panel everything is ok. But I have some problems. When I send an event for a roomExtension, an error occurred. The error is : Exception: com.smartfoxserver.v2....
by antuan
04 May 2012, 16:01
Forum: SFS2X Java / Android API
Topic: Custom login extension doesnt work!
Replies: 9
Views: 6263

Re: Custom login extension doesnt work!

If you installed the 2.1.0 patch on your previous RC3 version.. you made a mess! As reported in the requirements, the patch requires the final version, not the release candidate. Please install SFS2X from scratch getting it from the website, the patch it. I installed already the final release and p...
by antuan
04 May 2012, 13:57
Forum: SFS2X Java / Android API
Topic: Custom login extension doesnt work!
Replies: 9
Views: 6263

Re: Custom login extension doesnt work!

If you installed the 2.1.0 patch on your previous RC3 version.. you made a mess! As reported in the requirements, the patch requires the final version, not the release candidate. Please install SFS2X from scratch getting it from the website, the patch it. I installed already the final release and p...
by antuan
04 May 2012, 12:38
Forum: SFS2X Java / Android API
Topic: Custom login extension doesnt work!
Replies: 9
Views: 6263

Re: Custom login extension doesnt work!

Before reporting possible errors, please make sure you install the latest server version, patches and API updates. Pleas update and retest. Thanks. I installed the patch version 2.1.0, but the error still exist. The logs : 04 May 2012 | 14:34:28,033 | INFO | SocketReader | bitswarm.core.SocketAccep...
by antuan
04 May 2012, 07:36
Forum: SFS2X Java / Android API
Topic: Custom login extension doesnt work!
Replies: 9
Views: 6263

Re: Custom login extension doesnt work!

on your client you must be having a sfs = new SmartFox(); object right? do sfs.addEventListener (SFSEvent.login_error,handler); make sure that in your admin tool the use custom login is set to true for the zone configuration. Sfs can connect socket, get the room list or join a room. Everything work...
by antuan
04 May 2012, 07:27
Forum: SFS2X Java / Android API
Topic: Custom login extension doesnt work!
Replies: 9
Views: 6263

Re: Custom login extension doesnt work!

Hi. Are you using the latest SFS2X Final Release (2.0.1) alongside with the latest Java client API at http://www.smartfoxserver.com/download/sfs2x#p=updates? And what socket error are you getting on the client-side? The server version is SFS2X-PatchRC3 and there is no any error on the client side. ...
by antuan
03 May 2012, 13:02
Forum: SFS2X Java / Android API
Topic: Custom login extension doesnt work!
Replies: 9
Views: 6263

Custom login extension doesnt work!

Hello, I am trying to create a custom login extension. Everything works fine. When I send wrong login parameters, the socket throw an error, but user login successfully. The client side doesnt receive any error. I see the error on the system logs. My codes and logs is here: Client : public function ...

Go to advanced search