Search found 4 matches

by fotios
12 Feb 2010, 19:24
Forum: SmartFoxServer 1.x Discussions and Help
Topic: smarfox setup issue
Replies: 9
Views: 4425

fix to openinig port 9339 on ec2 for AdminTool

Try opening ud port 9339:
ec2-authorize group-name -P udp -p 9339

This fixed it for me. Then, try telnetting to 9339 on your ec2 instance. You should be able to connect to it.

The code from AdminTool.swf most probably uses udp to connect to the SF server.
by fotios
25 Nov 2009, 01:56
Forum: SmartFoxServer 1.x Discussions and Help
Topic: _sendRequest doesn't work
Replies: 1
Views: 1204

_sendRequest doesn't work

Hi there, I wrote an extension and used the _server.sendResponse in the following function: handleRequest(cmd, params, user, fromRoom, protocol) just like in the tutorial examples: var res = []; res[0] = "sr"; _server.sendResponse(res, -1, null, [user], "str"); (I tried many diff...
by fotios
05 Oct 2009, 23:16
Forum: Server Side Extension Development
Topic: Please, help with DB Connection
Replies: 6
Views: 4970

Thanks so much for the quick reply! Well, my code is very similar to yours. The problem might be with the ip of the mysql server. I use localhost now: <ConnectionString>jdbc:mysql://localhost:3306/smartfox_test</ConnectionString> Smartfox and my database are now installed on the same machine, so it ...
by fotios
05 Oct 2009, 09:51
Forum: Server Side Extension Development
Topic: Please, help with DB Connection
Replies: 6
Views: 4970

mysql connection

Hi there, I have the same problem (I guess) connecting SFS to mysql. I added the mysql jdbc (mysql-connector-java-5.0.8-bin.jar) connector under my ${JAVA_HOME}/lib/ext in redhat. I still get the same issue. SFS cannot connect with the mysql server. Can you please tell me how you fix it? I use the t...

Go to advanced search