server version question

Post here your questions about the HTML5 / JavaScript for SFS2X

Moderators: Lapo, Bax

endless30000
Posts: 5
Joined: 14 Jul 2016, 03:29

server version question

Postby endless30000 » 14 Jul 2016, 03:45

Our company's server version is 2.8.5, so we'd like to know if the sf2X version must be higher than 2.9 to support html5 client or websocket?
User avatar
Lapo
Site Admin
Posts: 19676
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: server version question

Postby Lapo » 14 Jul 2016, 09:26

Yes,
Websockets is supported since version 2.3.x

cheers
Lapo
--
gotoAndPlay()
...addicted to flash games
endless30000
Posts: 5
Joined: 14 Jul 2016, 03:29

Re: server version question

Postby endless30000 » 14 Jul 2016, 09:37

Lapo wrote:Yes,
Websockets is supported since version 2.3.x

cheers


hi,you mean that we must update to 2.9.x to support html5 client?
User avatar
Lapo
Site Admin
Posts: 19676
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: server version question

Postby Lapo » 14 Jul 2016, 13:36

No.
Version 2.3 is when we started supporting HTML5 websocket. Your run 2.8.
2.8 > 2.3

So, no problem :)
Lapo

--

gotoAndPlay()

...addicted to flash games
endless30000
Posts: 5
Joined: 14 Jul 2016, 03:29

Re: server version question

Postby endless30000 » 15 Jul 2016, 01:21

Lapo wrote:No.
Version 2.3 is when we started supporting HTML5 websocket. Your run 2.8.
2.8 > 2.3

So, no problem :)

Image
In version 2.8.5 I found it only has the first three options,this is not a problem yet?
and I use the h5 client api to connect server , it always error as below.
"WebSocket connection to 'ws://mydomain.com:9871/websocket' failed: Connection closed before receiving a handshake response".
is it means the client and the server are Inappropriate?
User avatar
Lapo
Site Admin
Posts: 19676
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: server version question

Postby Lapo » 15 Jul 2016, 07:17

I am not sure I understand. The error talks about port 9871 but the server config shows port 8888.
Looks like you're connecting to the wrong port...

Support for secure web sockets has been added in 2.9
Lapo

--

gotoAndPlay()

...addicted to flash games
endless30000
Posts: 5
Joined: 14 Jul 2016, 03:29

Re: server version question

Postby endless30000 » 15 Jul 2016, 08:49

Lapo wrote:I am not sure I understand. The error talks about port 9871 but the server config shows port 8888.
Looks like you're connecting to the wrong port...

Support for secure web sockets has been added in 2.9

sorry that pic is the example in your website.http://docs2x.smartfoxserver.com/GettingStarted/web-sockets
and I have some questions:
1. Can I use the html5 client API without the secure web sockets?

Yes
2. Why can't we connect to WebSocket? Is the version too old or because of the secure web sockets?

We need more details to be able to reply.
For example are you sure the server port is reachable? If a firewall is blocking the traffic you won't be able to connect. You can verify by telnetting the server on the target port.

3. Is there anything else that could happen if we haven't got the secure web sockets?

I am not sure what you mean.

If you want we can run a connection test from here. Send us your server's IP address, if it's reachable online. You can send me a PM or an email to support@...

thanks
endless30000
Posts: 5
Joined: 14 Jul 2016, 03:29

Re: server version question

Postby endless30000 » 16 Jul 2016, 10:46

endless30000 wrote:
Lapo wrote:I am not sure I understand. The error talks about port 9871 but the server config shows port 8888.
Looks like you're connecting to the wrong port...

Support for secure web sockets has been added in 2.9

sorry that pic is the example in your website.http://docs2x.smartfoxserver.com/GettingStarted/web-sockets
and I have some questions:
1. Can I use the html5 client API without the secure web sockets?

Yes
2. Why can't we connect to WebSocket? Is the version too old or because of the secure web sockets?

We need more details to be able to reply.
For example are you sure the server port is reachable? If a firewall is blocking the traffic you won't be able to connect. You can verify by telnetting the server on the target port.

3. Is there anything else that could happen if we haven't got the secure web sockets?

I am not sure what you mean.

If you want we can run a connection test from here. Send us your server's IP address, if it's reachable online. You can send me a PM or an email to support@...

thanks



hi I set up a new server with the 2.9 version , the html5 api can connect successful, so I think if I use the old version of Html5 client api, I can slove the problem, so where can I download the old version api?
User avatar
Lapo
Site Admin
Posts: 19676
Joined: 21 Mar 2005, 09:50
Location: Italy

Re: server version question

Postby Lapo » 16 Jul 2016, 15:36

The fact that you are having problems connecting has nothing to do with what version you're using.
Let's try to solve this issue, shall we? :)

First question: are you testing locally or remotely? If your server is online send us the IP address via email or PM so we can understand where the problem is.

thanks
Lapo

--

gotoAndPlay()

...addicted to flash games

Return to “SFS2X HTML5 / JavaScript API”

Who is online

Users browsing this forum: No registered users and 2 guests