RedBoxConnectionEvent.AV_CONNECTION_INITIALIZED not fired

Post your questions and bug-reports about our audio/video streaming add-on based on Red5 Server.

Moderators: Lapo, Bax

LeMageFou
Posts: 18
Joined: 19 Aug 2011, 15:51

RedBoxConnectionEvent.AV_CONNECTION_INITIALIZED not fired

Postby LeMageFou » 08 Feb 2012, 15:48

Hello.

When I connect to the Red5 server using the AVCastManager class, I don't get the event RedBoxConnectionEvent.AV_CONNECTION_INITIALIZED. I subscribed to the events like this :

Code: Select all

AVCManager = new AVCastManager(smartFox, SERVER_IP+":"+REDBOX_PORT);
AVCManager.addEventListener(RedBoxConnectionEvent.AV_CONNECTION_INITIALIZED, onAVConnectionInited);
AVCManager.addEventListener(RedBoxConnectionEvent.AV_CONNECTION_ERROR, onAVConnectionError);
AVCManager.addEventListener(RedBoxCastEvent.LIVE_CAST_PUBLISHED, onLiveCastPublished);


I don't get any RedBoxConnectionEvent events but I get the LIVE_CAST_PUBLISHED event (I can receive LiveCast).

Furthermore, the attribute isConnected of AVCastManager is always at false. So if I do something like this :

Code: Select all

if (AVCManager.isConnected)
{
   for each (var liveCast:LiveCast in AVCManager.getAvailableCasts())
   {
      AVCManager.subscribeLiveCast(liveCast.id);
   }
}

I don't get any LiveCast. But if I remove the isConnected test, I get the LiveCast.
User avatar
Bax
Site Admin
Posts: 4330
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Re: RedBoxConnectionEvent.AV_CONNECTION_INITIALIZED not fire

Postby Bax » 16 Feb 2012, 08:35

We never experienced this issues. We will check again as soon as possible. Thank you for reporting.
Paolo Bax
The SmartFoxServer Team

Return to “RedBox 2X”

Who is online

Users browsing this forum: No registered users and 1 guest