Error after client update (Polygonal DS)

Post here your questions about the OpenSpace 2.x or notify bugs and suggestions.

Moderators: Lapo, Bax

jadestein
Posts: 5
Joined: 10 Sep 2013, 14:29

Error after client update (Polygonal DS)

Postby jadestein » 10 Sep 2013, 15:00

Hi there,

we are recently in the progress of updating our Smartfox Server with the newest version (we're coming from v2 RC3).
After updating the Flash client Api to 1.1.7 the following error occurs:

Code: Select all

VerifyError: Error #1111: de.polygonal.ds::ListSet cannot implement de.polygonal.ds.Set


I read in other threads that people had this problem with older versions and that they should update to newer client versions. But we are using the newest version and are now getting this error.

Does someone has any idea why this happens?

Thank you very much!
User avatar
Bax
Site Admin
Posts: 4337
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Re: Error after client update (Polygonal DS)

Postby Bax » 10 Sep 2013, 15:45

Are you using OpenSpace or the Polygonal Data Structures library?
Paolo Bax
The SmartFoxServer Team
jadestein
Posts: 5
Joined: 10 Sep 2013, 14:29

Re: Error after client update (Polygonal DS)

Postby jadestein » 11 Sep 2013, 07:44

We are using OpenSpace 2.0.3.
User avatar
Bax
Site Admin
Posts: 4337
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Re: Error after client update (Polygonal DS)

Postby Bax » 11 Sep 2013, 08:27

You should update it to the latest version available (2.1).
If you received a download link when you purchased it, please re-download.
Otherwise please contact us by email sending the purchase invoice.
Paolo Bax
The SmartFoxServer Team
jadestein
Posts: 5
Joined: 10 Sep 2013, 14:29

Re: Error after client update (Polygonal DS)

Postby jadestein » 12 Sep 2013, 14:59

Thank you, updating OpenSpace did solve this problem! :)

But now I'm getting another error I can't get a handle on.

In our project I can visit a room just fine. The libs are loaded, the map is parsed rendered.
Then I leave this room and try to enter the same again.

The following error occurs:

Code: Select all

message = "Requesting map to OpenSpace Extension"
  message = "Map received from OpenSpace Extension"
  message = "Map parsing completed (6 ms)"
  message = "Map received from OpenSpace Extension"
Error: Error #2058: Fehler beim Dekomprimieren der Daten.
    at flash.utils::ByteArray/_uncompress()
    at flash.utils::ByteArray/uncompress()
    at com.smartfoxserver.openspace.engine.control::OpenSpaceController2X/onExtensionResponse()[/Users/Paolo/gotoAndPlay/gotoAndPlay/SmartFoxServer/OpenSpace/Client/Classes/src/com/smartfoxserver/openspace/engine/control/OpenSpaceController2X.as:1499]
    at flash.events::EventDispatcher/dispatchEventFunction()
    at flash.events::EventDispatcher/dispatchEvent()
    at com.smartfoxserver.v2.controllers::ExtensionController/handleMessage()[/Users/Paolo/gotoAndPlay/gotoAndPlay/SmartFoxServer2X/API/AS3/src/com/smartfoxserver/v2/controllers/ExtensionController.as:43]
    at com.smartfoxserver.v2.core::SFSProtocolCodec/dispatchRequest()[/Users/Paolo/gotoAndPlay/gotoAndPlay/SmartFoxServer2X/API/AS3/src/com/smartfoxserver/v2/core/SFSProtocolCodec.as:150]
    at com.smartfoxserver.v2.core::SFSProtocolCodec/onPacketRead()[/Users/Paolo/gotoAndPlay/gotoAndPlay/SmartFoxServer2X/API/AS3/src/com/smartfoxserver/v2/core/SFSProtocolCodec.as:54]
    at com.smartfoxserver.v2.core::SFSIOHandler/handlePacketData()[/Users/Paolo/gotoAndPlay/gotoAndPlay/SmartFoxServer2X/API/AS3/src/com/smartfoxserver/v2/core/SFSIOHandler.as:252]
    at com.smartfoxserver.v2.core::SFSIOHandler/onDataRead()[/Users/Paolo/gotoAndPlay/gotoAndPlay/SmartFoxServer2X/API/AS3/src/com/smartfoxserver/v2/core/SFSIOHandler.as:111]
    at com.smartfoxserver.v2.bitswarm::BitSwarmClient/onSocketData()[/Users/Paolo/gotoAndPlay/gotoAndPlay/SmartFoxServer2X/API/AS3/src/com/smartfoxserver/v2/bitswarm/BitSwarmClient.as:456]


Do you have any idea why this happens?
User avatar
Bax
Site Admin
Posts: 4337
Joined: 29 Mar 2005, 09:50
Location: Italy
Contact:

Re: Error after client update (Polygonal DS)

Postby Bax » 13 Sep 2013, 13:34

Not sure what is going on.
I tested the same scenario in our environment and no errors occurred.
Actually this was expected because the latest release shouldn't have impacts on the map loading and rendering process.

I tried the following:
1 - join a Room and enter its map
2 - leave the Room (with the LeaveRoomRequest) without resetting OpenSpace
3 - join the same Room again
The map is rendered as expected, without errors.

I also tried this:
1 - join a Room and enter its map
2 - reset OpenSpace
3 - leave the Room (with the LeaveRoomRequest)
3 - join the same Room again
Again everything works as expected.

We also tested with Rooms created dynamically when sending the user to his own "home".
Can you share more details on what you are doing?
Paolo Bax
The SmartFoxServer Team
jadestein
Posts: 5
Joined: 10 Sep 2013, 14:29

Re: Error after client update (Polygonal DS)

Postby jadestein » 17 Sep 2013, 10:15

Sorry for my late reply, Bax.

I believe the problem is solved! Indeed, OpenSpace was recreated each time a room was joined. Somehow the object was not destroyed correctly after leaving, so that which each joining of a room another load process was added (maps, libs, config, etc. were loaded two times for the second room, three times for the third, ...). I don't know why it was programmed that way. ;)

I've changed it and OpenSpace is created just once. Everything seems to working fine now.
Thank you SO much for your support and for directing me in the right direction. :)

Return to “OpenSpace v2 discussions and help”

Who is online

Users browsing this forum: No registered users and 3 guests