Memory management issue

Post here your questions about the OpenSpace 1.x or notify bugs and suggestions.

Moderators: Lapo, Bax

Posts: 8
Joined: 25 Mar 2010, 11:52

Memory management issue

Postby Olovarno » 08 Apr 2010, 13:28

Hi, guys!

We are having some critical memory management issue.

In our game, when we connected to world, it's using around 150 MB and 15% processing... That's ok...

After some minutes, it's using around 200 MB and 30% processing... It isn't ok!

After 30 or 40 minutes, it's using around 260 MP and 60% processing... Ok, it's critical!

In one of tests, after 40 minutes, my notebook crashed (I'm testing in a PC and notebook).

We've checked our code and actions we do while playing and we realized it uses more memory when going to other maps (independently on new map or map already visited).

We dowloaded bodyparts of avatar. To check it, we removed it but such issue persists, so it seems to be an OS issue when player visits several maps.

What can you say me? I'm using OS1, "seat programmer" licensed.
User avatar
Site Admin
Posts: 4355
Joined: 29 Mar 2005, 09:50
Location: Italy

Postby Bax » 12 Apr 2010, 17:24

We tested this deeply before releasing OpenSpace, and all tests always reported that all data structures are correctly garbage collected. For example if you test the example provided with OS and keep moving from map to map, you will see the memory increase and then collapse back as soon as the garbage collector does its job.
This makes us think that there's something else going on... maybe you are not releasing references to previously loaded objects? Also, are you using the same OS instance or you create a new one each time you load a new map?
Paolo Bax
The SmartFoxServer Team

Return to “OpenSpace v1 discussions and help”

Who is online

Users browsing this forum: No registered users and 3 guests